summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-28 00:48:47 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-28 00:48:47 +0100
commitcac6572a08e66d588f8c27f7305e06fa621f4a29 (patch)
tree3574408918460d947418d05fb33699db6cb84f91
parentx11-libs/goffice: Bump to 0.10.46 (diff)
downloadgentoo-cac6572a08e66d588f8c27f7305e06fa621f4a29.tar.gz
gentoo-cac6572a08e66d588f8c27f7305e06fa621f4a29.tar.bz2
gentoo-cac6572a08e66d588f8c27f7305e06fa621f4a29.zip
app-office/gnumeric: Bump to 1.12.46
* Remove support for the python loader, as it's unlikely that it will get ported to Python 3. Bug: https://bugs.gentoo.org/709018 Closes: https://bugs.gentoo.org/702432 Closes: https://bugs.gentoo.org/710846 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-office/gnumeric/Manifest1
-rw-r--r--app-office/gnumeric/gnumeric-1.12.46.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index 8ef19357413d..4c4a84ea5c27 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1,3 +1,4 @@
DIST gnumeric-1.12.39.tar.xz 20040688 BLAKE2B 5d99da20b567a939208881b962de3c79ab115a24953dc04d6c882e9a54946e5c5fbd32808a8006e396d70bc9a2a9783b20106536da1c19f7ed7dccd3b12c2fff SHA512 8ae09ea857989e65a8fe2070b30c2309d82daa4142816ef3a1b107035aea0d71498d84eaeeaa870a1587e3785146fad3304321a531c75f6e2f200def53a8e898
DIST gnumeric-1.12.43.tar.xz 18033636 BLAKE2B 32cbbefc10c0537b02b56564ed37f03d69d0865e9bd16dc8cb77aacf682087fce60f01a2e70b5dbef4d73840b6ccbe198d3c5cc5f13b0f1b2a48d0af635e607f SHA512 d2702000e6c4f4c0c7ff442a2b81e10f4d55f0cffbf7b7f1e7c9fed98fb46172b0118ca05102aa53fb4f953799e2be3534f0518b025ece26647ce67b870a34a7
DIST gnumeric-1.12.44.tar.xz 18010384 BLAKE2B 0348714a7dae119b36a6739ea499bc0411416637fe9cbd703024f4cdcdb894e2d4b0da3212ea6e2ad1dd81f893c96341722c83ef014db7f0a6f2a048696f41c6 SHA512 ea21dcdf5fdf4e02bb9d83671675f2409f12ee928611604d7589e0047ce5d75bf6ac51e6a5322c4af520428acdccf4c2b3b8e3fc6530030e162268aea94a503f
+DIST gnumeric-1.12.46.tar.xz 18282960 BLAKE2B f10fd8620dd2b865a4205b93f68ba78a07b94e72a147692bf875747cb8f128c54fad38e33162770d71422aed659f77b156679ca2f65836530c02b56cc2351ac6 SHA512 b3b3befe79f3ec8db6d7d9c80a1eed5293f5c0a9ca1d8dd131320eb031952b296147c51df1c775c6f9a0c466912e5523360373ee0b6e453e928929394ab517ea
diff --git a/app-office/gnumeric/gnumeric-1.12.46.ebuild b/app-office/gnumeric/gnumeric-1.12.46.ebuild
new file mode 100644
index 000000000000..4e1abd399e71
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.46.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit gnome.org libtool python-r1 xdg
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection libgda perl"
+REQUIRED_USE="introspection? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+# Gnumeric has two python components
+# 1. The python loader for loading python-based plugins.
+# This component is pure python 2 and a port "is not currently being worked on".
+# 2. The python gobject-based introspection API. This component is compatible
+# with python 3.
+# Component 1. can only be re-enabled once someone has ported the upstream
+# codebase to python 3.
+# https://gitlab.gnome.org/GNOME/gnumeric/issues/419#note_618852
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.40.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.46:0.10
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg]
+
+ introspection? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gobject-introspection-1:=
+ )
+ perl? ( dev-lang/perl:= )
+ libgda? ( gnome-extra/libgda:5[gtk] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/yelp-tools
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Manage gi overrides ourselves
+ sed '/SUBDIRS/ s/introspection//' -i Makefile.{am,in} || die
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --disable-schemas-compile \
+ --disable-static \
+ --without-psiconv \
+ --without-python \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl)
+}
+
+src_install() {
+ default
+ dodoc HACKING MAINTAINERS
+
+ if use introspection; then
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule introspection/gi/overrides/Gnm.py
+ fi
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}