summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-19 09:12:00 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-19 09:21:59 +0100
commitcaf94ad181303148d7b2013f4eab13e8494698ee (patch)
tree23d8fba6871ffc386f9a481f8a3ccdd64ac9a613
parentdev-embedded/u-boot-tools: bump up to 2020.04-r2 (diff)
downloadgentoo-caf94ad181303148d7b2013f4eab13e8494698ee.tar.gz
gentoo-caf94ad181303148d7b2013f4eab13e8494698ee.tar.bz2
gentoo-caf94ad181303148d7b2013f4eab13e8494698ee.zip
dev-python/uvloop: Bump to 0.15.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/uvloop/Manifest1
-rw-r--r--dev-python/uvloop/uvloop-0.15.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/uvloop/Manifest b/dev-python/uvloop/Manifest
index 47c79dc50fb6..c459c325c1cd 100644
--- a/dev-python/uvloop/Manifest
+++ b/dev-python/uvloop/Manifest
@@ -1,3 +1,4 @@
DIST uvloop-0.14.0.tar.gz 2009041 BLAKE2B 4d984f5023e0974ee68795e6cf29585cee32345e8a682611a72dbc36efefdfeeecb3c22aecb581ff7e5ae826345e1de3b0e6c7a6e8319829b0b3cbe5a180ed11 SHA512 8a9a64c91fd34c65a1c40d8d76ad7dbd7e959d45188ef81cdc06995312f52106b2c648a504d51b64b470e54dfc4854dcf9a05cafa3d4a42f1bc1e31766114d61
DIST uvloop-0.15.0.tar.gz 2086686 BLAKE2B 34bbce58f47a4da1c8fa27011c4a39e864ba1959affe2584eb33425ddb3fbb3a59783e3cf771669cdb1343299bbc7a7a8a14f4bfcbf2b694ac71b9fc055341d1 SHA512 fcb18511a1af89c11cd4022ecb6e8893915a159b34a054bab5e82da3b9127b886ab3e785a98ca39e612cdf2b18abd95bd7fc505808cccf9d4ac281f5a0b6e0d7
DIST uvloop-0.15.1.tar.gz 2087966 BLAKE2B 31892cfa2cacb02ae8a78ced2066a60012dfdc95ff9b1d68119487ec543e45fe7867c6a4b597b2ee83632c48d6d53216f648005a6202036e99f38b34b8d5e60a SHA512 104153760781b5596b552f00d0c897144fe2fbe208c2216e94daf5eef08ebde2ec45ddeaf6a24d1b28f9351d241832541a754124229af71245695da262458ffc
+DIST uvloop-0.15.2.tar.gz 2092589 BLAKE2B 05c518ba5854fa22fe72a0224856fa0529af0b9432f366b5b1cb0df09a92c787425713fadb85b151363df28800a94ed2a2ad617aaa1c4e854586e49d16f7dd1c SHA512 e398c7ff85da65344a6ab637e9b2f560e9ba61a3be7a3138d546138949359e30bc2e5f8268f1569b73c3881c66d71cf6298038ca1a883be71a33d7ef86d09eed
diff --git a/dev-python/uvloop/uvloop-0.15.2.ebuild b/dev-python/uvloop/uvloop-0.15.2.ebuild
new file mode 100644
index 000000000000..1ce46b172f5b
--- /dev/null
+++ b/dev-python/uvloop/uvloop-0.15.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Ultra-fast implementation of asyncio event loop on top of libuv"
+HOMEPAGE="https://github.com/magicstack/uvloop"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc examples"
+
+RDEPEND=">=dev-libs/libuv-1.11.0:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ cat <<EOF >> setup.cfg || die
+[build_ext]
+use-system-libuv=1
+EOF
+
+ # flake8 only
+ rm tests/test_sourcecode.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_ext --inplace build_sphinx
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && local HTML_DOCS=( "${BUILD_DIR}/sphinx/html/." )
+ distutils-r1_python_install_all
+}