summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2022-08-24 14:15:41 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2022-08-24 14:16:13 +0200
commitcb8523410bb6786ddf6c8fe933da23d8888d4aca (patch)
tree63a223d406332c3fdb0759c2a8eab0707ff40ec4
parentwww-client/firefox: restore keywords for 102.2.0 (diff)
downloadgentoo-cb8523410bb6786ddf6c8fe933da23d8888d4aca.tar.gz
gentoo-cb8523410bb6786ddf6c8fe933da23d8888d4aca.tar.bz2
gentoo-cb8523410bb6786ddf6c8fe933da23d8888d4aca.zip
net-wireless/gr-paint: add 0.0_p20220320
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
-rw-r--r--net-wireless/gr-paint/Manifest1
-rw-r--r--net-wireless/gr-paint/gr-paint-0.0_p20220320.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-wireless/gr-paint/Manifest b/net-wireless/gr-paint/Manifest
index d99d756e1194..df99fab8f292 100644
--- a/net-wireless/gr-paint/Manifest
+++ b/net-wireless/gr-paint/Manifest
@@ -1 +1,2 @@
DIST gr-paint-0.0_p20200517.tar.gz 1588114 BLAKE2B dffae6fdd6832ef7a39911b5f20d385e1691021e49659c36244c4aa1086fa74f4f59aceb4f208a24dd76854455183644c8f7db7e6ed0600664dc02f08e6682c5 SHA512 00b508b08baafd02e69197028a6408da81f5d1bf3dfe6d3229f248d60503ccec48f3fa0491bb785ed1ece40ea90d34544bc3b62e4506459488d56540b9d519c2
+DIST gr-paint-0.0_p20220320.tar.gz 2089721 BLAKE2B 50327bd2349177029e1c2fc3a7b3fe6df929487c456a6ae90f1233df7f8db02721bd0233e496cf4a00a9fa2164db705d995b1c2ec25e0a516a0672a6c2b5178d SHA512 b017fa41d8797182d752ad12bfe7511282d33bdfd87ea92dc86f6f01bbe5411759ed6bbfb0adb69368881fa231ee38e4c1eab47aebccdd64bd274f1f55ccac14
diff --git a/net-wireless/gr-paint/gr-paint-0.0_p20220320.ebuild b/net-wireless/gr-paint/gr-paint-0.0_p20220320.ebuild
new file mode 100644
index 000000000000..5f661be66d2c
--- /dev/null
+++ b/net-wireless/gr-paint/gr-paint-0.0_p20220320.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/drmpeg/gr-paint.git"
+else
+ COMMIT="6cf1568eb9e32c25bf6414ad45f75048a5a2b74c"
+ SRC_URI="https://github.com/drmpeg/gr-paint/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64"
+fi
+inherit cmake python-single-r1
+
+DESCRIPTION="Paints monochrome images into the waterfall of a receiver"
+HOMEPAGE="https://github.com/drmpeg/gr-paint"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+#< drmpeg> What tests?
+RESTRICT="test"
+
+DEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost:=[${PYTHON_USEDEP}]
+ ')
+ dev-libs/gmp
+ sci-libs/volk:=
+ sci-libs/fftw
+ >=net-wireless/gnuradio-3.9:=[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pygccxml[${PYTHON_USEDEP}]')
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ $(python_gen_cond_dep 'dev-python/pybind11[${PYTHON_USEDEP}]')
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DOXYGEN=$(usex doc)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ find "${D}" -name '*.py[oc]' -delete || die
+ python_optimize
+ mv "${ED}/usr/share/doc/gr-paint" "${ED}/usr/share/doc/${P}"
+}