summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-28 14:04:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-03-29 00:18:23 +0200
commitcc0c3fe81a0dd24e77d022b4b1a8ec387a86f27d (patch)
tree664cf86895728b3472df3ee3a393252ddd059533
parentdev-ros/collada_urdf: Bump to 1.12.8. (diff)
downloadgentoo-cc0c3fe81a0dd24e77d022b4b1a8ec387a86f27d.tar.gz
gentoo-cc0c3fe81a0dd24e77d022b4b1a8ec387a86f27d.tar.bz2
gentoo-cc0c3fe81a0dd24e77d022b4b1a8ec387a86f27d.zip
dev-ros/joint_state_publisher: Bump to 1.12.8.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-ros/joint_state_publisher/Manifest1
-rw-r--r--dev-ros/joint_state_publisher/joint_state_publisher-1.12.8.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/joint_state_publisher/Manifest b/dev-ros/joint_state_publisher/Manifest
index 1d1464f69e4b..c7052b0c98d8 100644
--- a/dev-ros/joint_state_publisher/Manifest
+++ b/dev-ros/joint_state_publisher/Manifest
@@ -1 +1,2 @@
DIST robot_model-1.12.7.tar.gz 1296028 SHA256 c9aad0e23970507c30490678fb76514faf1bd577ec2c30b4703fd322543be3bc SHA512 bc1901473f890b7200ef67db891ca9269c867ee1cf67a316948587d27549c6d58ce8c0b4a0d9255a5419a235ead3b19065b135486188efc21cbb6594d1863291 WHIRLPOOL 7575227d3388652eb71c5fd4265fe70c26f44149ee63d793ad87906805dff8938313f2f085edfee82847a4050b8639bc9c0773090b9f0ecbe84e29291f9d7593
+DIST robot_model-1.12.8.tar.gz 1297591 SHA256 dd8a6dec56e06bcc84582da4163efe22dcc4bf6badd6011ebb209db342c495a1 SHA512 77770e3ce1fe7c143c15581fa262dc01ccc04dd9313d022b9f0f254451db80415b558f339063debc5712590f846690d957848ba977f2175d2a4cda72b2102914 WHIRLPOOL afaeaee66821165efccc049a0f7972c597dde89f4f6814501694542e8d88d7591945872ca18020ea04742ab96ec133c306bccfddc81dd4f221b1def2f436cfbe
diff --git a/dev-ros/joint_state_publisher/joint_state_publisher-1.12.8.ebuild b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.8.ebuild
new file mode 100644
index 000000000000..7a7a68e62676
--- /dev/null
+++ b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.8.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_model"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for setting and publishing joint state values for a given URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"