summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-04 05:09:18 +0000
committerSam James <sam@gentoo.org>2022-11-04 05:09:18 +0000
commitcc40eb6f345c1193e853cb752bc8b727d6602e53 (patch)
tree814f203adce7e3158f73fe26883b82965695966f
parentdev-libs/kpathsea: fix configure w/ clang 16 (diff)
downloadgentoo-cc40eb6f345c1193e853cb752bc8b727d6602e53.tar.gz
gentoo-cc40eb6f345c1193e853cb752bc8b727d6602e53.tar.bz2
gentoo-cc40eb6f345c1193e853cb752bc8b727d6602e53.zip
app-text/dvisvgm: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/dvisvgm/dvisvgm-2.14-r1.ebuild (renamed from app-text/dvisvgm/dvisvgm-2.14.ebuild)12
-rw-r--r--app-text/dvisvgm/files/dvisvgm-2.14-configure-clang16.patch22
2 files changed, 33 insertions, 1 deletions
diff --git a/app-text/dvisvgm/dvisvgm-2.14.ebuild b/app-text/dvisvgm/dvisvgm-2.14-r1.ebuild
index 7a3027f6d6e0..7c440a044d8a 100644
--- a/app-text/dvisvgm/dvisvgm-2.14.ebuild
+++ b/app-text/dvisvgm/dvisvgm-2.14-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit autotools
+
DESCRIPTION="Converts DVI files to SVG"
HOMEPAGE="https://dvisvgm.de/"
SRC_URI="https://github.com/mgieseki/dvisvgm/releases/download/${PV}/${P}.tar.gz"
@@ -43,9 +45,17 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${P}-ghostscript.patch
- "${FILESDIR}"/${PN}-2.14-Add-missing-cstdint-includes-for-GCC-13.patch
+ "${FILESDIR}"/${P}-Add-missing-cstdint-includes-for-GCC-13.patch
+ "${FILESDIR}"/${PN}-2.14-configure-clang16.patch
)
+src_prepare() {
+ default
+
+ # Drop once configure patch merged for clang 16
+ eautoreconf
+}
+
src_configure() {
local myargs=(
--without-ttfautohint
diff --git a/app-text/dvisvgm/files/dvisvgm-2.14-configure-clang16.patch b/app-text/dvisvgm/files/dvisvgm-2.14-configure-clang16.patch
new file mode 100644
index 000000000000..6fe679f551d1
--- /dev/null
+++ b/app-text/dvisvgm/files/dvisvgm-2.14-configure-clang16.patch
@@ -0,0 +1,22 @@
+https://github.com/mgieseki/dvisvgm/pull/200
+
+From e3cfc0976ec1f5bbcd389c318eabc2a783990de0 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Fri, 4 Nov 2022 05:07:09 +0000
+Subject: [PATCH] configure.ac: fix -Wimplicit-function-declaration
+
+Clang 16 makes -Wimplicit-function-declaration an error by default. We
+need to include <stdlib.h> for exit().
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,6 +55,7 @@ AC_CHECK_LIB([kpathsea], [kpse_find_file],,
+
+ AC_MSG_CHECKING([kpathsea version])
+ AC_RUN_IFELSE([AC_LANG_SOURCE([#include <stdio.h>
++ #include <stdlib.h>
+ #include <kpathsea/kpathsea.h>
+ int main() {
+ FILE *f;
+