summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-07-11 14:02:39 -0400
committerMike Pagano <mpagano@gentoo.org>2022-07-11 14:03:41 -0400
commitcccacbae494c2783b04aefa08d0c55295343c8f5 (patch)
treef4809e6ec731ba5e405dd4afbe217faf1b8f03b1
parentnet-libs/libosmo-dsp: Drop .la file (diff)
downloadgentoo-cccacbae494c2783b04aefa08d0c55295343c8f5.tar.gz
gentoo-cccacbae494c2783b04aefa08d0c55295343c8f5.tar.bz2
gentoo-cccacbae494c2783b04aefa08d0c55295343c8f5.zip
app-portage/portpeek: Version bump with support for python 3.11
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--app-portage/portpeek/portpeek-3.2.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-portage/portpeek/portpeek-3.2.2-r1.ebuild b/app-portage/portpeek/portpeek-3.2.2-r1.ebuild
new file mode 100644
index 000000000000..459e51243625
--- /dev/null
+++ b/app-portage/portpeek/portpeek-3.2.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{8,9,10,11} )
+
+inherit python-r1
+
+DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
+HOMEPAGE="https://github.com/mpagano/portpeek"
+SRC_URI="https://github.com/mpagano/portpeek/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.6.1-r1
+ || (
+ >=sys-apps/portage-3.0.31[${PYTHON_USEDEP}]
+ )"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ doman *.[0-9]
+}