summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-03-01 12:59:49 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-03-01 13:01:50 -0600
commitcd4ae3f1c3ef7e3d7690de661731084a626fab29 (patch)
treeb333df98350e16b9d4a2c7f8466b5dafd45881d6
parentnet-im/skypeforlinux: add 8.81.0.268 (diff)
downloadgentoo-cd4ae3f1c3ef7e3d7690de661731084a626fab29.tar.gz
gentoo-cd4ae3f1c3ef7e3d7690de661731084a626fab29.tar.bz2
gentoo-cd4ae3f1c3ef7e3d7690de661731084a626fab29.zip
app-admin/ansible-base: 2.12.3 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/ansible-base/Manifest1
-rw-r--r--app-admin/ansible-base/ansible-base-2.12.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-admin/ansible-base/Manifest b/app-admin/ansible-base/Manifest
index 847aa0e09b0f..bcb5baa9fffa 100644
--- a/app-admin/ansible-base/Manifest
+++ b/app-admin/ansible-base/Manifest
@@ -1,2 +1,3 @@
DIST ansible-core-2.11.7.tar.gz 7108269 BLAKE2B c5080161bfffc34382db86f3940dbbf1c8194a4413b20ef28b3c15503aec905acfffc864041496b4f6b4b77966fee3221b80e90d4b952e38513ba9ce506ee1ae SHA512 f37c925c5302eff30d17f52a04d4a5311e38ee5c1d6db4fbdb32970afa362e0522d6ec3d07bddf40137b2f5ec5fa03a2b72e7e1ed313c28c207f65490e49af92
DIST ansible-core-2.12.2.tar.gz 7750306 BLAKE2B 629ff38ad98eebdf6b8d7f47355f065589c511fb66b19543ad696b973f6a776b420158ce157c0af5f14b85574808bd5bf3f285607e588949f6cd2e232941e508 SHA512 a9afc3768d27a7049c275da8780e6dcd7da42263fc9065a1df1aabd0d8c54020313e9065349a6f52138e11eafb176348bf2ec33c0c1b08dc9837b7ac832542af
+DIST ansible-core-2.12.3.tar.gz 7757271 BLAKE2B 02c8c2c09b778de9775384471f0b485237a8074468d437d41a6879e85769444c91ed4571e17de9aa4024fb2b6c29b4e90b4c31b6714d633ef7028e9711f5ecf3 SHA512 dedac2546881442f5e904c485bdc464d0ced847520879fd10c2454a2055ada4d051416d450f01ae5a1e2f5073f1633cb4db5265855199bb32c0acb41092d6f05
diff --git a/app-admin/ansible-base/ansible-base-2.12.3.ebuild b/app-admin/ansible-base/ansible-base-2.12.3.ebuild
new file mode 100644
index 000000000000..06d9ba54c027
--- /dev/null
+++ b/app-admin/ansible-base/ansible-base-2.12.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansible/ansible.git"
+ EGIT_BRANCH="devel"
+else
+ MY_PN="${PN/-base/-core}"
+ MY_P="${MY_PN}-${PV}"
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+ S="${WORKDIR}"/${MY_P}
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-0.5.3[${PYTHON_USEDEP}]
+ <dev-python/resolvelib-0.6.0[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile() {
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}