summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-27 10:05:17 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-27 11:51:32 +0100
commitce1ffc855e423e2dd653a4930e511c34dd19a6ea (patch)
treedaad4e31e8b8a9b877c9f4112e192eab26513ebc
parentdev-python/Nuitka: Bump to 1.4 (diff)
downloadgentoo-ce1ffc855e423e2dd653a4930e511c34dd19a6ea.tar.gz
gentoo-ce1ffc855e423e2dd653a4930e511c34dd19a6ea.tar.bz2
gentoo-ce1ffc855e423e2dd653a4930e511c34dd19a6ea.zip
net-misc/electrum: Bump to 4.3.4
Closes: https://bugs.gentoo.org/867817 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-misc/electrum/Manifest1
-rw-r--r--net-misc/electrum/electrum-4.3.4.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/net-misc/electrum/Manifest b/net-misc/electrum/Manifest
index ba5e6e950a80..c70dd058d84d 100644
--- a/net-misc/electrum/Manifest
+++ b/net-misc/electrum/Manifest
@@ -1,2 +1,3 @@
DIST electrum-4.3.2.gh.tar.gz 5460546 BLAKE2B b2367116aef2a2a76dca30a635188bcd99f0fdd46ce6e8c5a2d6608fbb8f0a58e88b8352c5db92b7c8709f7bbc420fc1860204aca1efc2f2c4be2c788bfa1909 SHA512 dfb137e01ca6e511fb5ac70c34dcb01f36bdb209d7d290bd53c8fa5f95783f346898478d6e58435b241928dfe05ff46455e2e587520d47892c66b3198ab89c82
DIST electrum-4.3.3.gh.tar.gz 5511225 BLAKE2B dd7700d185ad1d8d58c609a3b388fc4764eca68eb20bb2254046daa5faa5e790fe31a61536ab086a6f632f42346cf22121a3b85b85ae1d45ab8f59ad49e66455 SHA512 33e357d49a0839b269bf8eb5a617b9a866a85a4953a109a382930718ce204a36a93638be1d9111ca9a5349f0aed496e86f5f2b43ffa8b1ce6683c50a8b76ec6c
+DIST electrum-4.3.4.gh.tar.gz 5512701 BLAKE2B a57e3ffddacfd5c63dc7f5cb59bbfe06323e7c8ab708d49e1301356fdcc0204e8126894c3c4b6dd790bd8e64cabc84a410592ea94b361cc553d4dcaa5921f50e SHA512 dc821cbda2e95853627b141292da5a07d8a672cfaabb0b160c67b3020442416593136984b42bf021f815e22671fbded67e6d2dee95e4e46f63e5c9a8fe01ebc9
diff --git a/net-misc/electrum/electrum-4.3.4.ebuild b/net-misc/electrum/electrum-4.3.4.ebuild
new file mode 100644
index 000000000000..526eb9a1a6bd
--- /dev/null
+++ b/net-misc/electrum/electrum-4.3.4.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_REQ_USE="ncurses?"
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="User friendly Bitcoin client"
+HOMEPAGE="
+ https://electrum.org/
+ https://github.com/spesmilo/electrum/
+"
+SRC_URI="
+ https://github.com/spesmilo/electrum/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cli ncurses qrcode +qt5"
+REQUIRED_USE="|| ( cli ncurses qt5 )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ <dev-libs/libsecp256k1-0.2
+ >=dev-python/aiohttp-socks-0.3[${PYTHON_USEDEP}]
+ =dev-python/aiorpcX-0.22*[${PYTHON_USEDEP}]
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ dev-python/bitstring[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2[${PYTHON_USEDEP}]
+ dev-python/pbkdf2[${PYTHON_USEDEP}]
+ dev-python/PySocks[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.12[${PYTHON_USEDEP}]
+ qrcode? ( media-gfx/zbar[v4l] )
+ qt5? (
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ )
+ ncurses? ( $(python_gen_impl_dep 'ncurses') )
+"
+BDEPEND="
+ test? (
+ dev-python/pyaes[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # use backwards-compatible cryptodome API
+ sed -i -e 's:Cryptodome:Crypto:' electrum/crypto.py || die
+
+ # make qdarkstyle dep optional
+ sed -i -e '/qdarkstyle/d' contrib/requirements/requirements.txt || die
+
+ local bestgui
+ if use qt5; then
+ bestgui=qt
+ elif use ncurses; then
+ bestgui=text
+ else
+ bestgui=stdio
+ fi
+ sed -i 's/^\([[:space:]]*\)\(config_options\['\''cwd'\''\] = .*\)$/\1\2\n\1config_options.setdefault("gui", "'"${bestgui}"'")\n/' ${PN}/${PN} || die
+
+ eapply_user
+
+ xdg_environment_reset
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ dodoc RELEASE-NOTES
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ ver_test "${v}" -ge 4.3.4 && return
+ done
+
+ ewarn "If you are new to BitCoin, please be aware that:"
+ ewarn "1. Cryptocurrencies are volatile. BTC has been subject to rapid"
+ ewarn " changes of value in the past."
+ ewarn "2. Cryptocurrency ownership is determined solely by the access to"
+ ewarn " the private key. If the key is lost or stolen, BTC are unrevocably"
+ ewarn " lost."
+ ewarn "3. Proof-of-work based cryptocurrencies have negative environmental"
+ ewarn " impact. BTC mining is consuming huge amounts of electricity."
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}