summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2021-01-06 23:49:01 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-01-06 23:49:20 -0800
commitce6b22969843e35cb265cc98d6952b1adece0d12 (patch)
tree2a19d10a302f87d5b73e291305383451f7bbaacb
parentdev-ruby/sanitize: drop x86-macos (diff)
downloadgentoo-ce6b22969843e35cb265cc98d6952b1adece0d12.tar.gz
gentoo-ce6b22969843e35cb265cc98d6952b1adece0d12.tar.bz2
gentoo-ce6b22969843e35cb265cc98d6952b1adece0d12.zip
app-misc/tmuxp-1.6.4: Version bump
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--app-misc/tmuxp/Manifest1
-rw-r--r--app-misc/tmuxp/files/tmuxp-1.6.4-tests.patch22
-rw-r--r--app-misc/tmuxp/tmuxp-1.6.4.ebuild45
3 files changed, 68 insertions, 0 deletions
diff --git a/app-misc/tmuxp/Manifest b/app-misc/tmuxp/Manifest
index 1e0abca880de..2c372c437f90 100644
--- a/app-misc/tmuxp/Manifest
+++ b/app-misc/tmuxp/Manifest
@@ -2,3 +2,4 @@ DIST tmuxp-1.5.4.tar.gz 843048 BLAKE2B 863b428198e8bb2895802ba7365ac2ec43fc75c70
DIST tmuxp-1.5.5.tar.gz 856665 BLAKE2B fa18222840b9c221de48a78291243776a66a7aec3221f23be3218f81eae0d15ce5a4568f7eff679c01793d4ac4d441f6714c37d9ac3c9f705af49214f5dc2570 SHA512 61c14197af7742b48dab95443bb818ede20d26aa46ab2e89b883a34e2bcec910d8210fc1358fc88f96ccc637c47d6432082cd58995b80a43234cebba95240ebc
DIST tmuxp-1.5.6.tar.gz 883700 BLAKE2B c8ad08c709aa1763cc046a05c6241983d2cdd33ca530ce0510ae7bb68ce3e340d40c6ec23c9544ef8b0d8da38aad74305e13d7b6348b0f46da929e94b3e862ff SHA512 1db74aa9ee6274aacec127aff210e8ed64176142991a9691c31c59ef0370503dddeb35b69c0a8229204968308c68788d408d6a5e0bc2ad1fb3320727ea4994f9
DIST tmuxp-1.6.2.tar.gz 1014758 BLAKE2B c6c60978938892311151cfff35bdc74e2daa9a615b2952a14c4a0020e434af7c28d36466a5ae82db683c6bda9a95f12f7e032d04eb58c5b164aeb05b144b2005 SHA512 a38c3f46a726df0cd885113d82ed5a186d68f6d643a7bde6d169908373e6881fac14c8c46c00ede727e47e4e1af5f9d3cd79cb0057457478ace1ec0ba0632cfb
+DIST tmuxp-1.6.4.tar.gz 1015684 BLAKE2B 4f8d34ab1e1bd8e46e89e49ac92ce0a05b614bd7b43ce910120f12a46fb3ab143330975352cf2275999146ba005646c7c5aa07b7cc616ae80265edb4e173cf34 SHA512 482ba47652090a13d7866695b2639ab580c0cca5f6935f58e0be6867efde298c6f3350f65c231dec59a3f2dc1e0f795b02df1ad24d5ace6e7ee6aecdd60a9611
diff --git a/app-misc/tmuxp/files/tmuxp-1.6.4-tests.patch b/app-misc/tmuxp/files/tmuxp-1.6.4-tests.patch
new file mode 100644
index 000000000000..4bdfe015474a
--- /dev/null
+++ b/app-misc/tmuxp/files/tmuxp-1.6.4-tests.patch
@@ -0,0 +1,22 @@
+diff --git a/tests/test_cli.py b/tests/test_cli.py
+index 1e14e51..6945c2b 100644
+--- a/tests/test_cli.py
++++ b/tests/test_cli.py
+@@ -486,7 +486,7 @@ session_name: hello
+ '{SESSION_NAME}',
+ '{WINDOW_NAME}',
+ '-c',
+- 'print(pane.id)',
++ 'print(getattr(pane, "id", "{PANE_ID}"))',
+ ],
+ [],
+ {},
+@@ -496,7 +496,7 @@ session_name: hello
+ [
+ '-L{SOCKET_NAME}',
+ '-c',
+- 'print(pane.id)',
++ 'print(getattr(pane, "id", "{PANE_ID}"))',
+ ],
+ [],
+ {'TMUX_PANE': '{PANE_ID}'},
diff --git a/app-misc/tmuxp/tmuxp-1.6.4.ebuild b/app-misc/tmuxp/tmuxp-1.6.4.ebuild
new file mode 100644
index 000000000000..e4f93be9b6db
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.6.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ >=dev-python/kaptan-0.5.10[${PYTHON_USEDEP}]
+ >=dev-python/libtmux-0.8.5[${PYTHON_USEDEP}]
+ <dev-python/libtmux-0.9[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ <dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-4.1.1[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/tmuxp-1.6.4-tests.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ SHELL="/bin/bash" pytest -vv || die "Tests fail with ${EPYTHON}"
+}