summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-19 05:17:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-19 05:17:44 +0100
commitce745b23835dcb11a693996c5b8244b33b94fde3 (patch)
tree8484e5dd218a49829717eab19b4ab25ade19775a
parentdev-python/recurring-ical-events: Bump to 2.0.2 (diff)
downloadgentoo-ce745b23835dcb11a693996c5b8244b33b94fde3.tar.gz
gentoo-ce745b23835dcb11a693996c5b8244b33b94fde3.tar.bz2
gentoo-ce745b23835dcb11a693996c5b8244b33b94fde3.zip
dev-python/caldav: Bump to 1.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/caldav/Manifest1
-rw-r--r--dev-python/caldav/caldav-1.1.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/caldav/Manifest b/dev-python/caldav/Manifest
index e0073ecc3695..aaf6e525b538 100644
--- a/dev-python/caldav/Manifest
+++ b/dev-python/caldav/Manifest
@@ -1 +1,2 @@
DIST caldav-1.0.1.gh.tar.gz 133071 BLAKE2B d7b9eb8015782bed5d32b7c34508cfcc1334d33cdfed99003cf45893b0a894d5a3187a2c98f886f97ffe8a64140a5a3826e1b3f57b58228a61d1ad4f9bf9f72a SHA512 ac816afd74f6fe34d82345a8b3a934fbe2c37af6a75cc8ef91cd87c8b8d147962ff05e701cd91480c1963d57967898129f923655d366820b689959b00f55659f
+DIST caldav-1.1.1.gh.tar.gz 136513 BLAKE2B a825b19023cadfd2b59e747c5d1b00065530d6773435a9f363d54cea7621f56eb6207b7a2888994fe5c42b873d6b82ba285abbc2ee5d18f72aafd90271cc5e87 SHA512 a1d991d468f093e6d54262f657e6e43ea9bf9e55dbe1f2fcb7189fb1e6a742805faee2a99807838f5db3406c1a9cd72a14054a30efe13e8d5ad7f113aaa88e2a
diff --git a/dev-python/caldav/caldav-1.1.1.ebuild b/dev-python/caldav/caldav-1.1.1.ebuild
new file mode 100644
index 000000000000..8f1601942874
--- /dev/null
+++ b/dev-python/caldav/caldav-1.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="CalDAV (RFC4791) client library for Python"
+HOMEPAGE="
+ https://github.com/python-caldav/caldav/
+ https://pypi.org/project/caldav/
+"
+SRC_URI="
+ https://github.com/python-caldav/caldav/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( GPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/recurring-ical-events[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ www-apps/radicale[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest