summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-26 17:16:48 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-27 22:09:28 +0100
commitcea9a32d1acd79e89520b6aa6f6a550f3372af11 (patch)
tree3de6d4efae9ef249de0fa2bbb7adfd58229c7e8b
parentada.eclass: drop gnat_2020 from ada.eclass (diff)
downloadgentoo-cea9a32d1acd79e89520b6aa6f6a550f3372af11.tar.gz
gentoo-cea9a32d1acd79e89520b6aa6f6a550f3372af11.tar.bz2
gentoo-cea9a32d1acd79e89520b6aa6f6a550f3372af11.zip
app-misc/openrgb: update patch in 9999 ebuild
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/28439 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--app-misc/openrgb/files/OpenRGB-0.8-plugins.patch26
-rw-r--r--app-misc/openrgb/openrgb-9999.ebuild2
2 files changed, 27 insertions, 1 deletions
diff --git a/app-misc/openrgb/files/OpenRGB-0.8-plugins.patch b/app-misc/openrgb/files/OpenRGB-0.8-plugins.patch
new file mode 100644
index 000000000000..a2d02cde3c7f
--- /dev/null
+++ b/app-misc/openrgb/files/OpenRGB-0.8-plugins.patch
@@ -0,0 +1,26 @@
+Allow installation of plugins not only in ~/.config
+
+Used by app-misc/openrgb-plugin-* packages
+
+diff --git a/PluginManager.cpp b/PluginManager.cpp
+index 6ccad72c..7b12f32e 100644
+--- a/PluginManager.cpp
++++ b/PluginManager.cpp
+@@ -41,7 +41,8 @@ void PluginManager::ScanAndLoadPlugins()
+ | The plugins directory is a directory named "plugins" in |
+ | the configuration directory |
+ \*---------------------------------------------------------*/
+- const QDir plugins_dir = QString(ResourceManager::get()->GetConfigurationDirectory().c_str()).append(plugins_path);
++ for (const QDir plugins_dir : {QString(ResourceManager::get()->GetConfigurationDirectory().c_str()).append(plugins_path),
++ QString().fromStdString(GENTOO_PLUGINS_DIR)}) {
+ LOG_INFO("[PluginManager] Scanning plugin directory: %s", plugins_dir.absolutePath().toStdString().c_str());
+
+ /*---------------------------------------------------------*\
+@@ -64,6 +65,7 @@ void PluginManager::ScanAndLoadPlugins()
+
+ AddPlugin(plugin_path);
+ }
++ }
+ }
+
+ void PluginManager::AddPlugin(std::string path)
diff --git a/app-misc/openrgb/openrgb-9999.ebuild b/app-misc/openrgb/openrgb-9999.ebuild
index 44c450e3c857..74083c048810 100644
--- a/app-misc/openrgb/openrgb-9999.ebuild
+++ b/app-misc/openrgb/openrgb-9999.ebuild
@@ -40,7 +40,7 @@ BDEPEND="
"
PATCHES+=(
- "${FILESDIR}"/OpenRGB-0.7-plugins.patch
+ "${FILESDIR}"/OpenRGB-0.8-plugins.patch
"${FILESDIR}"/OpenRGB-0.7-r1-udev.patch
)