summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-02 23:08:12 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-02 23:29:24 +0200
commitceac2c53741cde2446ce458a60b09082e6756c2a (patch)
tree7c5d69c69d6f678d275e717263c37d85490dc03a
parentnet-mail/notmuch: Bump version (diff)
downloadgentoo-ceac2c53741cde2446ce458a60b09082e6756c2a.tar.gz
gentoo-ceac2c53741cde2446ce458a60b09082e6756c2a.tar.bz2
gentoo-ceac2c53741cde2446ce458a60b09082e6756c2a.zip
app-office/lyx: Fix build with automake-1.16
Bug: https://bugs.gentoo.org/648318 Bug: https://bugs.gentoo.org/631798 Thanks-to: pavel sanda <ps@twin.jikos.cz> Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--app-office/lyx/files/lyx-2.3.0-autotools.patch27
-rw-r--r--app-office/lyx/lyx-2.3.0.ebuild1
2 files changed, 28 insertions, 0 deletions
diff --git a/app-office/lyx/files/lyx-2.3.0-autotools.patch b/app-office/lyx/files/lyx-2.3.0-autotools.patch
new file mode 100644
index 00000000000..31077ef02a6
--- /dev/null
+++ b/app-office/lyx/files/lyx-2.3.0-autotools.patch
@@ -0,0 +1,27 @@
+Index: INSTALL
+===================================================================
+--- a/INSTALL (revision 9aa280993f159f065da82d5fac30eb86a6599f4d)
++++ b/INSTALL (revision 3abfd72b2720c21eba51bb2338f0b8b835dae720)
+@@ -38,5 +38,5 @@
+
+ If you have checked this out from Git, you need to have:
+-* automake (supported versions are 1.14--1.15)
++* automake (supported versions are 1.14--1.16)
+ * autoconf (supported versions are 2.65--2.69)
+ Then type "./autogen.sh" to build the needed configuration
+Index: autogen.sh
+===================================================================
+--- a/autogen.sh (revision 86ae7dad3fc1cad3744663d0da8034625dc9ffb1)
++++ b/autogen.sh (revision 3abfd72b2720c21eba51bb2338f0b8b835dae720)
+@@ -17,9 +17,9 @@
+
+ case $automake_version in
+- *' '1.1[45]*)
++ *' '1.1[456]*)
+ ;;
+ *)
+ echo "This automake version is not supported by LyX."
+- echo "LyX only supports automake 1.14 to 1.15."
++ echo "LyX only supports automake 1.14 through 1.16."
+ exit 1
+ ;;
diff --git a/app-office/lyx/lyx-2.3.0.ebuild b/app-office/lyx/lyx-2.3.0.ebuild
index ad0929130f0..8ae1f6e35db 100644
--- a/app-office/lyx/lyx-2.3.0.ebuild
+++ b/app-office/lyx/lyx-2.3.0.ebuild
@@ -79,6 +79,7 @@ DOCS=( ANNOUNCE NEWS README RELEASE-NOTES UPGRADING )
PATCHES=(
"${FILESDIR}"/${P}-python.patch
"${FILESDIR}"/${P}-qt-5.11.patch
+ "${FILESDIR}"/${P}-autotools.patch
)
S="${WORKDIR}/${MY_P}"