summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2022-02-02 10:17:40 +0100
committerFabian Groffen <grobian@gentoo.org>2022-02-02 10:18:24 +0100
commitcef87d59020e99f6cd0c62ca6aa113fe98fe30d9 (patch)
treeab81f5a8f02510696d9dfc73a73083608180e57a
parentnet-im/skypeforlinux: require glibc (diff)
downloadgentoo-cef87d59020e99f6cd0c62ca6aa113fe98fe30d9.tar.gz
gentoo-cef87d59020e99f6cd0c62ca6aa113fe98fe30d9.tar.bz2
gentoo-cef87d59020e99f6cd0c62ca6aa113fe98fe30d9.zip
app-shells/tcsh-6.23.02: version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--app-shells/tcsh/Manifest1
-rw-r--r--app-shells/tcsh/files/tcsh-6.23.02-dircolors.patch27
-rw-r--r--app-shells/tcsh/tcsh-6.23.02.ebuild110
3 files changed, 138 insertions, 0 deletions
diff --git a/app-shells/tcsh/Manifest b/app-shells/tcsh/Manifest
index a8941cee354e..7512bb2c7c91 100644
--- a/app-shells/tcsh/Manifest
+++ b/app-shells/tcsh/Manifest
@@ -1,3 +1,4 @@
DIST tcsh-6.22.02.tar.gz 1006405 BLAKE2B f18b2c48958b4d38a0f55b0df8563564b2a3b34becf02eda8802d7f5e2194082bf96c46323d606c2e6bd2a26aaed303bae3132d03515274407c63b713583dde7 SHA512 32d271b568c63265ea4c98494f5e60b37c3a3fc2594e8763b8f6f0b09018ab9db7ef6f951120b37f7880ccf04ba3a2559e30dc08d24f4ba9dc36853238d55980
DIST tcsh-6.22.04.tar.gz 1012977 BLAKE2B 5702e17e25603a244e4481294cbe2dc2272d4f3ac8362be9e1dd65f3857e0e54520a245d321dda5ef747345776c22068dcb130705daddf71cb650b154ed96ba4 SHA512 3956df52124d496dc0e67e4e3e801787f31690f96a60399953e401648d5b4cfb06baa9833c32cb771177b3e89b7a27e5765534db073206568fe773598a55e873
+DIST tcsh-6.23.02.tar.gz 947265 BLAKE2B f1f6e1b98458a847e55802cdad14cbecb1ed222e18d8fd2547da7765e0658b645685f0baebcf5f08f237a94c7b56ba400d1e51f1743798b8acd375726772825c SHA512 bf83987e4667e3e514b99b6ee0a7f04c8eafad2bdb20f480e2a3614fc2112e01a75d3fcbf43ce54a4ef6d12a03693c3446ae6e14daa91f0ae7556019de1bce2a
DIST tcsh-gentoo-patches-r1.9.tar.bz2 2488 BLAKE2B 58924e623c75068cdc686be61755bdbcf8d0949a2141ac532ac089f80ff083b2c9f6767038b9fc52171a00ed82c558b83216327c87b41f51c3648343869cd5b6 SHA512 9903e9c3e2279abcac09a3235f3c5db9f42156c18137eb651ede195ca2b069f0b5bc6105fed33666b69796c4ebf03e4efe63cd9beba1898bac7297a2f74bfd3d
diff --git a/app-shells/tcsh/files/tcsh-6.23.02-dircolors.patch b/app-shells/tcsh/files/tcsh-6.23.02-dircolors.patch
new file mode 100644
index 000000000000..2fb21476fd29
--- /dev/null
+++ b/app-shells/tcsh/files/tcsh-6.23.02-dircolors.patch
@@ -0,0 +1,27 @@
+Based on original Debian patch, updated from 6.14 to 6.20 and 6.23
+
+silently ignore bad colour variables, for defaults have unsupported ones
+
+https://bugs.gentoo.org/120792
+
+--- a/tw.color.c
++++ b/tw.color.c
+@@ -381,16 +381,14 @@
+ if ((Char)variables[i].variable[0] == (v[0] & CHAR) &&
+ (Char)variables[i].variable[1] == (v[1] & CHAR))
+ break;
++ v += 3;
+ if (i < nvariables) {
+- v += 3;
+ getstring(&c, &v, &variables[i].color, ':');
+ if (i == VSym)
+ color_as_referent = strcasecmp(
+ variables[VSym].color.s, "target") == 0;
+- continue;
+ }
+- else
+- stderror(ERR_BADCOLORVAR, v[0], v[1]);
++ continue;
+ }
+ break;
+ }
diff --git a/app-shells/tcsh/tcsh-6.23.02.ebuild b/app-shells/tcsh/tcsh-6.23.02.ebuild
new file mode 100644
index 000000000000..272be1706d35
--- /dev/null
+++ b/app-shells/tcsh/tcsh-6.23.02.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic autotools prefix
+
+CONFVER="1.9"
+
+DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+HOMEPAGE="https://www.tcsh.org/"
+SRC_URI="
+ ftp://ftp.astron.com/pub/tcsh/${P}.tar.gz
+ https://dev.gentoo.org/~grobian/distfiles/tcsh-gentoo-patches-r${CONFVER}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls doc"
+RESTRICT="test"
+
+# we need gettext because we run autoconf (AM_ICONV)
+RDEPEND="
+ >=sys-libs/ncurses-5.1:0=
+ virtual/libcrypt:=
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ doc? ( dev-lang/perl )"
+
+CONFDIR=${WORKDIR}/tcsh-gentoo-patches-r${CONFVER}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.23.02-dircolors.patch # bug #120792
+ "${FILESDIR}"/${PN}-6.21.04-no-nls.patch
+ "${FILESDIR}"/${PN}-6.21.00-use-ncurses.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ # fix gencat usage
+ sed \
+ -e 's/cat \$\^ \$> | \$(GENCAT) \$@/rm -f $@; $(GENCAT) $@ $> $^/' \
+ -i nls/Makefile.in || die
+
+ # always use sysmalloc, the builtin malloc fails on Darwin, musl,
+ # etc. it's already used for glibc-linux, so this doesn't change
+ # anything for the majority of users
+ sed -i -e 's/undef SYSMALLOC/define SYSMALLOC/' config_f.h || die
+
+ # unify ECHO behaviour
+ echo "#undef ECHO_STYLE" >> config_f.h
+ echo "#define ECHO_STYLE BOTH_ECHO" >> config_f.h
+
+ eprefixify "${CONFDIR}"/*
+ # activate the right default PATH
+ if [[ -z ${EPREFIX} ]] ; then
+ sed -i \
+ -e 's/^#MAIN//' -e '/^#PREFIX/d' \
+ "${CONFDIR}"/csh.login || die
+ else
+ sed -i \
+ -e 's/^#PREFIX//' -e '/^#MAIN/d' \
+ "${CONFDIR}"/csh.login || die
+ fi
+
+ eapply_user
+}
+
+src_configure() {
+ # make tcsh look and live along the lines of the prefix
+ append-cppflags -D_PATH_DOTCSHRC="'"'"${EPREFIX}/etc/csh.cshrc"'"'"
+ append-cppflags -D_PATH_DOTLOGIN="'"'"${EPREFIX}/etc/csh.login"'"'"
+ append-cppflags -D_PATH_DOTLOGOUT="'"'"${EPREFIX}/etc/csh.logout"'"'"
+ append-cppflags -D_PATH_USRBIN="'"'"${EPREFIX}/usr/bin"'"'"
+ append-cppflags -D_PATH_BIN="'"'"${EPREFIX}/bin"'"'"
+
+ # musl's utmp is non-functional
+ if use elibc_musl ; then
+ export ac_cv_header_utmp_h=no
+ export ac_cv_header_utmpx_h=no
+ fi
+
+ econf \
+ --prefix="${EPREFIX:-}" \
+ --datarootdir='${prefix}/usr/share' \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install.man
+
+ DOCS=( FAQ Fixes NewThings Ported README.md WishList Y2K )
+ if use doc ; then
+ perl tcsh.man2html tcsh.man || die
+ HTML_DOCS=( tcsh.html/*.html )
+ fi
+ einstalldocs
+
+ insinto /etc
+ doins \
+ "${CONFDIR}"/csh.cshrc \
+ "${CONFDIR}"/csh.login
+
+ # bug #119703: add csh -> tcsh symlink
+ dosym tcsh /bin/csh
+}