summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2022-06-08 14:32:36 +0200
committerSam James <sam@gentoo.org>2022-06-16 17:30:15 +0100
commitcf31223386f826c2804e243647758a9ebb5da1ab (patch)
tree3ded181c8a52649bcffde975a51a4abe8f84d4c2
parentdev-python/pyroute2: Add myself as maintainer (diff)
downloadgentoo-cf31223386f826c2804e243647758a9ebb5da1ab.tar.gz
gentoo-cf31223386f826c2804e243647758a9ebb5da1ab.tar.bz2
gentoo-cf31223386f826c2804e243647758a9ebb5da1ab.zip
dev-python/pyroute2: bump to 0.5.19
Closes: https://bugs.gentoo.org/813990 Signed-off-by: Henning Schild <henning@hennsch.de> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pyroute2/Manifest1
-rw-r--r--dev-python/pyroute2/files/pyroute2-0.5.19-exclude-tests.patch13
-rw-r--r--dev-python/pyroute2/pyroute2-0.5.19.ebuild26
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyroute2/Manifest b/dev-python/pyroute2/Manifest
index e997e6d6e5c2..9109b75b72ca 100644
--- a/dev-python/pyroute2/Manifest
+++ b/dev-python/pyroute2/Manifest
@@ -1 +1,2 @@
DIST pyroute2-0.5.14.tar.gz 436853 BLAKE2B 9febcd6563d89b5ffd71342d8d83a3251494f978ad4449532b568cf0929c9f3d8d8d36e1a0b0f6733013e12f6322aea46d991a22f5c3fa93e47dfa08376ddd13 SHA512 9601cf8133b703c55770b6292cca1e907a029689aaeb350b6eee40406b56de5563ee0ba37b4814540c365a5974be78a024dcb27bc7ee00eac74676f4013cf277
+DIST pyroute2-0.5.19.gh.tar.gz 457432 BLAKE2B ffb2717c60badb1453eeb15f5b83f1494e851ee011fcdebd3a5d249ecc4bea7064069a1af2fe2d34aefe9812c8b6808b8a14cbe518383c165b0b008d10505c5c SHA512 19b0acbff17415acad20a214e0622ca9a3fc51b92e603ab15663ea7e8da290fc0b2033aeca1c20200307e34173802f89998151f77d5bcfc5f87eb8b42ba591ce
diff --git a/dev-python/pyroute2/files/pyroute2-0.5.19-exclude-tests.patch b/dev-python/pyroute2/files/pyroute2-0.5.19-exclude-tests.patch
new file mode 100644
index 000000000000..723c638349b7
--- /dev/null
+++ b/dev-python/pyroute2/files/pyroute2-0.5.19-exclude-tests.patch
@@ -0,0 +1,13 @@
+Index: pyroute2-0.5.19/setup.cfg
+===================================================================
+--- pyroute2-0.5.19.orig/setup.cfg
++++ pyroute2-0.5.19/setup.cfg
+@@ -35,5 +35,8 @@ packages_dir =
+ =pyroute2
+ packages = find:
+
++[options.packages.find]
++exclude = tests
++
+ [options.extras_require]
+ ss2 = psutil~=5.0
diff --git a/dev-python/pyroute2/pyroute2-0.5.19.ebuild b/dev-python/pyroute2/pyroute2-0.5.19.ebuild
new file mode 100644
index 000000000000..fd09b9995879
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.5.19.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8,9,10} pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library"
+HOMEPAGE="https://github.com/svinota/pyroute2"
+SRC_URI="
+ https://github.com/svinota/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-exclude-tests.patch"
+)
+
+# tests need root access
+RESTRICT="test"