summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-08-09 15:05:48 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-08-09 16:47:21 -0700
commitcfffec5d3b243be7afd3d01c8a8b60efa874cda4 (patch)
treea4f5081f797103edcef64c091e4a670913d2a03b
parentdev-python/pyjade: New package, dep of buildbot-0.9 (diff)
downloadgentoo-cfffec5d3b243be7afd3d01c8a8b60efa874cda4.tar.gz
gentoo-cfffec5d3b243be7afd3d01c8a8b60efa874cda4.tar.bz2
gentoo-cfffec5d3b243be7afd3d01c8a8b60efa874cda4.zip
dev-python/txrequests: New package, dep of buildbot-0.9
Package-Manager: portage-2.3.0
-rw-r--r--dev-python/txrequests/Manifest1
-rw-r--r--dev-python/txrequests/metadata.xml24
-rw-r--r--dev-python/txrequests/txrequests-0.9.2.ebuild28
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/txrequests/Manifest b/dev-python/txrequests/Manifest
new file mode 100644
index 000000000000..ef9ea5e28bc0
--- /dev/null
+++ b/dev-python/txrequests/Manifest
@@ -0,0 +1 @@
+DIST txrequests-0.9.2.tar.gz 5223 SHA256 dc29e7c9305a74be3e88cd0253bde1981855426e39fbf4a7f4af647542eb7d4e SHA512 99ea6ed752e23f6539cbf571b304fab3b73a173ce23e6688889191d377961c68773513d9602e0600b45f454c99051f527f7719f7712e2b8e91696afa0c405c95 WHIRLPOOL 5721d372157d1ea9b65650a8a7d1685495144bd2c5eb4dd5810f7cf37780121b3a89eeecc928750d5893d5541e9e7011ff86e8d93feb81bb97ad9a78aada7412
diff --git a/dev-python/txrequests/metadata.xml b/dev-python/txrequests/metadata.xml
new file mode 100644
index 000000000000..028d3e54a055
--- /dev/null
+++ b/dev-python/txrequests/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dol-sen@gentoo.org</email>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>tardyp@gmail.com</email>
+ <name>Pierre Tardy</name>
+ </maintainer>
+ <remote-id type="pypi">txrequests</remote-id>
+ </upstream>
+ <longdescription>Small add-on for the python requests http library.
+ Makes use twisted's ThreadPool, so that the requests'API returns
+ deferred. The additional API and changes are minimal and strives to
+ avoid surprises.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/txrequests/txrequests-0.9.2.ebuild b/dev-python/txrequests/txrequests-0.9.2.ebuild
new file mode 100644
index 000000000000..e44e4770a85d
--- /dev/null
+++ b/dev-python/txrequests/txrequests-0.9.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7)
+
+inherit distutils-r1
+
+DESCRIPTION="Asynchronous Python HTTP for Humans"
+HOMEPAGE="https://github.com/tardyp/txrequests"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/requests-1.2.0[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/twisted-core-9.0.0[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"