summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2018-06-23 18:49:31 -0400
committerNick Sarnie <sarnex@gentoo.org>2018-06-23 18:50:11 -0400
commitd166c4dd2313efb74fb1b30b668e7e48e08b4098 (patch)
treecc624499687ef717f64a1edf38ff1182435349d1
parentdev-python/brython: version bump. (diff)
downloadgentoo-d166c4dd2313efb74fb1b30b668e7e48e08b4098.tar.gz
gentoo-d166c4dd2313efb74fb1b30b668e7e48e08b4098.tar.bz2
gentoo-d166c4dd2313efb74fb1b30b668e7e48e08b4098.zip
media-libs/vulkan-loader: Bump to 1.1.77.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--media-libs/vulkan-loader/Manifest1
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-1.1.77.0.ebuild59
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-9999.ebuild5
3 files changed, 63 insertions, 2 deletions
diff --git a/media-libs/vulkan-loader/Manifest b/media-libs/vulkan-loader/Manifest
index 0e4ad6f0f75e..434c609df81c 100644
--- a/media-libs/vulkan-loader/Manifest
+++ b/media-libs/vulkan-loader/Manifest
@@ -1 +1,2 @@
DIST vulkan-loader-1.1.70.0.tar.gz 4107351 BLAKE2B 86859e74839a0a7c667476db62a1bc73d89f22e6bb951f2742bc6990ed498e9201bd17973e887f360b2eec610e29d547e79d5323ed74fd5618cb0fc75dbba063 SHA512 ae57e6890225b6e4607fde04a296a14bc54fd6b61b360b771bd24f00607dcb6fff06b3ec38a761173c92c90628a139f1424445e174c21adad4af6f445b91ed26
+DIST vulkan-loader-1.1.77.0.tar.gz 1512876 BLAKE2B bf5fbf3623f0ca2b2473d496edd23ce388313d7dbeb8e3f95549da5726a1ab25fcce673d5dd3df094d3abdd2c5ecc4a87759a80e7d05d7b34abf30ee325895f2 SHA512 95fe179c93df1ea36cee8123588b232433c988e9a5889a606e7adbc4192d6a4bc8809f9936cf11ae953090392d0c9e4265697b608adacc7eb7cf6479baf49f48
diff --git a/media-libs/vulkan-loader/vulkan-loader-1.1.77.0.ebuild b/media-libs/vulkan-loader/vulkan-loader-1.1.77.0.ebuild
new file mode 100644
index 000000000000..4f7ccd73988b
--- /dev/null
+++ b/media-libs/vulkan-loader/vulkan-loader-1.1.77.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-Loader.git"
+ EGIT_SUBMODULES=()
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="c71d5027a9d7fe4b170c0ff69bad67efd1d530cf"
+ SRC_URI="https://github.com/KhronosGroup/Vulkan-Loader/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Vulkan-Loader-${EGIT_COMMIT}"
+fi
+
+inherit python-any-r1 cmake-multilib
+
+DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
+HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Loader"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="layers wayland X"
+
+PDEPEND="layers? ( media-libs/vulkan-layers:=[${MULTILIB_USEDEP}] )"
+DEPEND="${PYTHON_DEPS}
+ dev-util/vulkan-headers
+ wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
+ X? (
+ x11-libs/libX11:=[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
+ )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=True
+ -DBUILD_TESTS=False
+ -DBUILD_LOADER=True
+ -DBUILD_WSI_MIR_SUPPORT=False
+ -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
+ -DBUILD_WSI_XCB_SUPPORT=$(usex X)
+ -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
+ -DVULKAN_HEADERS_INSTALL_DIR="/usr"
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_install() {
+ keepdir /etc/vulkan/icd.d
+
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ einfo "USE=demos has been dropped as per upstream packaging"
+ einfo "vulkaninfo is now available in the dev-util/vulkan-tools package"
+}
diff --git a/media-libs/vulkan-loader/vulkan-loader-9999.ebuild b/media-libs/vulkan-loader/vulkan-loader-9999.ebuild
index 9e7474822138..4f7ccd73988b 100644
--- a/media-libs/vulkan-loader/vulkan-loader-9999.ebuild
+++ b/media-libs/vulkan-loader/vulkan-loader-9999.ebuild
@@ -10,8 +10,9 @@ if [[ "${PV}" == "9999" ]]; then
inherit git-r3
else
KEYWORDS="~amd64"
- SRC_URI="https://github.com/KhronosGroup/Vulkan-Loader/archive/sdk-${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/Vulkan-Loader-sdk-${PV}"
+ EGIT_COMMIT="c71d5027a9d7fe4b170c0ff69bad67efd1d530cf"
+ SRC_URI="https://github.com/KhronosGroup/Vulkan-Loader/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Vulkan-Loader-${EGIT_COMMIT}"
fi
inherit python-any-r1 cmake-multilib