summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-08-22 11:53:37 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-08-22 11:53:37 +0200
commitd18d89cdd674b7eb62619f8cc4b583e358ee7a43 (patch)
tree9556fa75061d2dde59b2835d7bb3b73938a3615b
parentdev-libs/urdfdom: Add missing dep on dev-libs/tinyxml. (diff)
downloadgentoo-d18d89cdd674b7eb62619f8cc4b583e358ee7a43.tar.gz
gentoo-d18d89cdd674b7eb62619f8cc4b583e358ee7a43.tar.bz2
gentoo-d18d89cdd674b7eb62619f8cc4b583e358ee7a43.zip
media-video/ffmpeg: Check for -mcpu, then -march and finally -mtune for determining cpu type.
Should fix https://bugs.gentoo.org/show_bug.cgi?id=553632 Package-Manager: portage-2.2.20.1
-rw-r--r--media-video/ffmpeg/ffmpeg-2.6.3.ebuild2
-rw-r--r--media-video/ffmpeg/ffmpeg-2.6.4.ebuild2
-rw-r--r--media-video/ffmpeg/ffmpeg-2.7.2.ebuild2
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild2
4 files changed, 4 insertions, 4 deletions
diff --git a/media-video/ffmpeg/ffmpeg-2.6.3.ebuild b/media-video/ffmpeg/ffmpeg-2.6.3.ebuild
index fb7c820039ef..2f513ba70b81 100644
--- a/media-video/ffmpeg/ffmpeg-2.6.3.ebuild
+++ b/media-video/ffmpeg/ffmpeg-2.6.3.ebuild
@@ -364,7 +364,7 @@ multilib_src_configure() {
# We need to do this so that features of that CPU will be better used
# If they contain an unknown CPU it will not hurt since ffmpeg's configure
# will just ignore it.
- for i in $(get-flag mcpu) $(get-flag mtune) $(get-flag march) ; do
+ for i in $(get-flag mcpu) $(get-flag march) $(get-flag mtune) ; do
[[ ${i} = native ]] && i="host" # bug #273421
myconf+=( --cpu=${i} )
break
diff --git a/media-video/ffmpeg/ffmpeg-2.6.4.ebuild b/media-video/ffmpeg/ffmpeg-2.6.4.ebuild
index c970d54625f9..f4e269cfb2ff 100644
--- a/media-video/ffmpeg/ffmpeg-2.6.4.ebuild
+++ b/media-video/ffmpeg/ffmpeg-2.6.4.ebuild
@@ -364,7 +364,7 @@ multilib_src_configure() {
# We need to do this so that features of that CPU will be better used
# If they contain an unknown CPU it will not hurt since ffmpeg's configure
# will just ignore it.
- for i in $(get-flag mcpu) $(get-flag mtune) $(get-flag march) ; do
+ for i in $(get-flag mcpu) $(get-flag march) $(get-flag mtune) ; do
[[ ${i} = native ]] && i="host" # bug #273421
myconf+=( --cpu=${i} )
break
diff --git a/media-video/ffmpeg/ffmpeg-2.7.2.ebuild b/media-video/ffmpeg/ffmpeg-2.7.2.ebuild
index 280e101cd368..c568a8f7a547 100644
--- a/media-video/ffmpeg/ffmpeg-2.7.2.ebuild
+++ b/media-video/ffmpeg/ffmpeg-2.7.2.ebuild
@@ -364,7 +364,7 @@ multilib_src_configure() {
# We need to do this so that features of that CPU will be better used
# If they contain an unknown CPU it will not hurt since ffmpeg's configure
# will just ignore it.
- for i in $(get-flag mcpu) $(get-flag mtune) $(get-flag march) ; do
+ for i in $(get-flag mcpu) $(get-flag march) $(get-flag mtune) ; do
[[ ${i} = native ]] && i="host" # bug #273421
myconf+=( --cpu=${i} )
break
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index ca8ee9ff8c25..fa8dea8b74c5 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -366,7 +366,7 @@ multilib_src_configure() {
# We need to do this so that features of that CPU will be better used
# If they contain an unknown CPU it will not hurt since ffmpeg's configure
# will just ignore it.
- for i in $(get-flag mcpu) $(get-flag mtune) $(get-flag march) ; do
+ for i in $(get-flag mcpu) $(get-flag march) $(get-flag mtune) ; do
[[ ${i} = native ]] && i="host" # bug #273421
myconf+=( --cpu=${i} )
break