summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-12-13 22:55:03 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-12-13 23:00:32 -0500
commitd18fd39f084e51731f23ccdfd8a40da725c300d7 (patch)
treed69d2e9ae0f282e1fab16ce8bcfe90f60d72c2c2
parentx11-libs/libxshmfence: Version bump to 1.3.3 (diff)
downloadgentoo-d18fd39f084e51731f23ccdfd8a40da725c300d7.tar.gz
gentoo-d18fd39f084e51731f23ccdfd8a40da725c300d7.tar.bz2
gentoo-d18fd39f084e51731f23ccdfd8a40da725c300d7.zip
sci-mathematics/flint: fix C23 build, switch back to autotools
Upstream has mentioned a few times that the cmake build system is only supported on Windows, so here's an attempt to switch it (back) to autotools. Also adds a patch for C23 compatibility. Closes: https://bugs.gentoo.org/944848 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-mathematics/flint/Manifest1
-rw-r--r--sci-mathematics/flint/files/flint-3.1.3_p1-c23.patch31
-rw-r--r--sci-mathematics/flint/flint-3.1.3_p1-r2.ebuild112
3 files changed, 144 insertions, 0 deletions
diff --git a/sci-mathematics/flint/Manifest b/sci-mathematics/flint/Manifest
index f1fe7fc91c54..92c86791f40e 100644
--- a/sci-mathematics/flint/Manifest
+++ b/sci-mathematics/flint/Manifest
@@ -1 +1,2 @@
DIST flint-3.1.3_p1.tar.gz 7588734 BLAKE2B 87acf8778e21e37c01e12b198ff81e62ab113df3e0e9c6155ff7dd505828f79d5c49d85093e261ea96397e906350caa03477e3ecbdd1fc09d6ae5c984397a2be SHA512 1b16ff2fb9cb2ac4b75513278b8c14683e8d83db39985631df14d6ea74bee4d6ea818a200321d5f0de6f1af89898f7a99dc7088f712f4c6db1a2546199aefba7
+DIST flint-3.1.3_p1.tar.xz 5657304 BLAKE2B 7a76cbd7e3ea6ecfb4728545c427eba48ab476b257316792305522770e03b335d558cc104bac50b1faf2e8e25663f6ade20eef99e85999f7209091bf3c6e674a SHA512 430e83be2d94c059066b7201319dbbbe414ccd10a4f359a865e54f3912b8b8e8f10dfd36ee81c96335553ee2736cf2ef9e1ffdf488c9706360b9e0e8a50a4eea
diff --git a/sci-mathematics/flint/files/flint-3.1.3_p1-c23.patch b/sci-mathematics/flint/files/flint-3.1.3_p1-c23.patch
new file mode 100644
index 000000000000..43f69603e3e0
--- /dev/null
+++ b/sci-mathematics/flint/files/flint-3.1.3_p1-c23.patch
@@ -0,0 +1,31 @@
+From ee516836e58327310ca58f10f71ae8873b0320e0 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Mon, 25 Nov 2024 22:22:02 -0500
+Subject: [PATCH] src/flint.h.in: fix "noreturn" attribute in C23 mode
+
+C23 uses [[noreturn]] for this, just like C++.
+
+Signed-off-by: Michael Orlitzky <michael@orlitzky.com>
+---
+ src/flint.h.in | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/src/flint.h.in b/src/flint.h.in
+index a574fc8a26..5b95ea5fe3 100644
+--- a/src/flint.h.in
++++ b/src/flint.h.in
+@@ -156,12 +156,10 @@ typedef const ulong * nn_srcptr;
+ # define FLINT_DEPRECATED
+ #endif
+
+-#if defined(__cplusplus)
++#if defined(__cplusplus) || ( __STDC_VERSION__ >= 202300L )
+ # define FLINT_NORETURN [[noreturn]]
+-#elif __STDC_VERSION__ < 202300L
+-# define FLINT_NORETURN _Noreturn
+ #else
+-# define FLINT_NORETURN noreturn
++# define FLINT_NORETURN _Noreturn
+ #endif
+
+ #if FLINT_USES_TLS
diff --git a/sci-mathematics/flint/flint-3.1.3_p1-r2.ebuild b/sci-mathematics/flint/flint-3.1.3_p1-r2.ebuild
new file mode 100644
index 000000000000..841de4da69e3
--- /dev/null
+++ b/sci-mathematics/flint/flint-3.1.3_p1-r2.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} python3_13t )
+inherit flag-o-matic python-any-r1
+
+DESCRIPTION="Fast Library for Number Theory"
+HOMEPAGE="https://www.flintlib.org/"
+
+MY_PV="${PV/_/-}"
+SRC_URI="https://github.com/flintlib/flint/releases/download/v${MY_PV}/flint-${MY_PV}.tar.xz -> ${P}.tar.xz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+LICENSE="LGPL-2.1+"
+
+# Based off the soname, e.g. /usr/lib64/libflint.so -> libflint.so.15
+SLOT="0/19"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc ntl test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="${PYTHON_DEPS}
+ doc? (
+ app-text/texlive-core
+ dev-python/sphinx
+ dev-tex/latexmk
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+ ntl? ( dev-libs/ntl )
+"
+
+# NTL is never linked
+DEPEND="dev-libs/gmp:=
+ dev-libs/mpfr:=
+ virtual/cblas"
+
+# Flint 3.x includes arb. We include some version of NTL here if USE=ntl
+# is set so that consumers can depend on flint[ntl] to get a usable
+# Flint-NTL interface. But otherwise, NTL isn't actually needed at
+# runtime, even if Flint was built with USE=ntl.
+RDEPEND="${DEPEND}
+ ntl? ( dev-libs/ntl )
+ !sci-mathematics/arb"
+
+# The rst files are API docs, but they're very low-effort compared to
+# the PDF and HTML docs, so we ship them unconditionally and hide only
+# the painful parts behind USE=doc.
+DOCS="AUTHORS README.md doc/source/*.rst"
+
+PATCHES=(
+ "${FILESDIR}/flint-3.0.1-find-cblas.patch"
+ "${FILESDIR}/flint-3.1.3_p1-c99-I.patch"
+ "${FILESDIR}/flint-3.1.3_p1-fix-pc-location.patch"
+ "${FILESDIR}/flint-3.1.3_p1-c23.patch"
+)
+
+src_configure() {
+ # Test failures:
+ # * https://bugs.gentoo.org/934463
+ # * https://github.com/flintlib/flint/issues/2029
+ filter-flags -floop-nest-optimize \
+ -ftree-loop-linear \
+ -floop-strip-mine \
+ -floop-block \
+ -fgraphite-identity
+
+ # ABI needs to be unset because flint uses it internally for
+ # an incompatible purpose.
+ # --enable-debug just adds -g to your CFLAGS
+ # --enable-avx2 and --enable-avx512 just add "-mfoo" to CFLAGS
+ # --enable-gc affects thread-safety
+ local myeconfargs=(
+ ABI=""
+ --disable-debug
+ --with-blas
+ --with-gmp
+ --with-mpfr
+ --without-gc
+ )
+
+ # The NTL interface consists of a single header, NTL-interface.h,
+ # that is always installed. USE=ntl only determines whether or not
+ # the corresponding tests (which actually use NTL) are built and
+ # run. As a result, we don't care about USE=ntl without USE=test.
+ use test && myeconfargs+=( $(use_with ntl) )
+ econf "${myeconfargs[@]}"
+
+ if use doc; then
+ # Avoid the "html/_sources" directory that will contain a copy
+ # of the rst sources we've already installed, and also avoid
+ # installing html/objects.inv.
+ HTML_DOCS="doc/build/html/*.html
+ doc/build/html/*.js
+ doc/build/html/_static"
+ DOCS+=" doc/build/latex/Flint.pdf"
+ fi
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ pushd doc
+ emake html
+ emake latexpdf
+ popd
+ fi
+}