summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-01-21 11:17:21 +0100
committerHans de Graaff <graaff@gentoo.org>2018-01-21 11:38:40 +0100
commitd1b15d57a9ef8e43dae954f5d961f69550781bbe (patch)
tree4871f193a43f0cd25a61812fcf113afc7b8629c8
parentsys-libs/glibc: reenable stack protection on mips, bug #640130 (diff)
downloadgentoo-d1b15d57a9ef8e43dae954f5d961f69550781bbe.tar.gz
gentoo-d1b15d57a9ef8e43dae954f5d961f69550781bbe.tar.bz2
gentoo-d1b15d57a9ef8e43dae954f5d961f69550781bbe.zip
Move current ruby23 status into arch profiles, bug 639476
Mask ruby_targets_ruby23 in the use.stable.mask of each arch and set RUBY_TARGETS to ruby22 in the make.defaults for each arch. This makes it possible to update the defaults in the main profile for a stable ruby:2.3 slot and consequently to mark ruby:2.3 stable on each arch in turn making sure that users of that arch will not end up with conflicting settings (e.g. stable ruby:2.3 but RUBY_TARGETS="ruby22"). Each arch is expected to remove these temporary entries as they mark ruby:2.3 stable, as per the instructions in bug 639476.
-rw-r--r--profiles/arch/alpha/make.defaults4
-rw-r--r--profiles/arch/alpha/use.stable.mask4
-rw-r--r--profiles/arch/amd64/make.defaults4
-rw-r--r--profiles/arch/amd64/use.stable.mask4
-rw-r--r--profiles/arch/arm/make.defaults3
-rw-r--r--profiles/arch/arm/use.stable.mask4
-rw-r--r--profiles/arch/hppa/make.defaults4
-rw-r--r--profiles/arch/hppa/use.stable.mask4
-rw-r--r--profiles/arch/ia64/make.defaults4
-rw-r--r--profiles/arch/ia64/use.stable.mask4
-rw-r--r--profiles/arch/powerpc/ppc32/make.defaults4
-rw-r--r--profiles/arch/powerpc/ppc32/use.stable.mask4
-rw-r--r--profiles/arch/powerpc/ppc64/make.defaults4
-rw-r--r--profiles/arch/powerpc/ppc64/use.stable.mask4
-rw-r--r--profiles/arch/sparc/make.defaults4
-rw-r--r--profiles/arch/sparc/use.stable.mask4
-rw-r--r--profiles/arch/x86/make.defaults4
-rw-r--r--profiles/arch/x86/use.stable.mask4
18 files changed, 71 insertions, 0 deletions
diff --git a/profiles/arch/alpha/make.defaults b/profiles/arch/alpha/make.defaults
index 25c2ed44634..c57fc9bfb4a 100644
--- a/profiles/arch/alpha/make.defaults
+++ b/profiles/arch/alpha/make.defaults
@@ -27,3 +27,7 @@ VIDEO_CARDS="fbdev glint mach64 mga nv r128 radeon savage tdfx voodoo"
# Defaults for audio drivers. These are copied from x86 (minus modems), since
# Alpha supports the same busses.
ALSA_CARDS="ali5451 als4000 bt87x ca0106 cmipci emu10k1 ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 maestro3 trident usb-audio via82xx ymfpci"
+
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary entry to support stable bug 639476
+RUBY_TARGETS="ruby22"
diff --git a/profiles/arch/alpha/use.stable.mask b/profiles/arch/alpha/use.stable.mask
index 7ef77fce94b..aec25237e08 100644
--- a/profiles/arch/alpha/use.stable.mask
+++ b/profiles/arch/alpha/use.stable.mask
@@ -4,6 +4,10 @@
# This file requires eapi 5 or later. New entries go on top.
# Please use the same syntax as in use.mask
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary mask to support stable bug 639476
+ruby_targets_ruby23
+
# Brian Evans <grknight@gentoo.org> (16 Dec 2017)
# Needs dev-lang/php:7.1 stable
php_targets_php7-1
diff --git a/profiles/arch/amd64/make.defaults b/profiles/arch/amd64/make.defaults
index 1ca36a8d4f3..db2969eaa8d 100644
--- a/profiles/arch/amd64/make.defaults
+++ b/profiles/arch/amd64/make.defaults
@@ -62,3 +62,7 @@ USE_EXPAND_HIDDEN="-ABI_X86 -CPU_FLAGS_X86"
# Make the native ABI implicit so that MULTILIB_USEDEP can be satisfied
# by non-multilib ebuilds when non-native ABIs are disabled.
IUSE_IMPLICIT="abi_x86_64"
+
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary entry to support stable bug 639476
+RUBY_TARGETS="ruby22"
diff --git a/profiles/arch/amd64/use.stable.mask b/profiles/arch/amd64/use.stable.mask
index 2bf7d3769e7..8508f7f2dee 100644
--- a/profiles/arch/amd64/use.stable.mask
+++ b/profiles/arch/amd64/use.stable.mask
@@ -4,6 +4,10 @@
# This file requires eapi 5 or later. New entries go on top.
# Please use the same syntax as in use.mask
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary mask to support stable bug 639476
+ruby_targets_ruby23
+
# Michael Palimaka <kensington@gentoo.org> (03 Jun 2017)
# Not yet stable.
elogind
diff --git a/profiles/arch/arm/make.defaults b/profiles/arch/arm/make.defaults
index c0a917b65d7..410843f5d63 100644
--- a/profiles/arch/arm/make.defaults
+++ b/profiles/arch/arm/make.defaults
@@ -23,3 +23,6 @@ VIDEO_CARDS="exynos fbdev omap"
# Unhide the ARM-specific USE_EXPANDs.
USE_EXPAND_HIDDEN="-CPU_FLAGS_ARM"
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary entry to support stable bug 639476
+RUBY_TARGETS="ruby22"
diff --git a/profiles/arch/arm/use.stable.mask b/profiles/arch/arm/use.stable.mask
index 71be5d31fbc..34affefc969 100644
--- a/profiles/arch/arm/use.stable.mask
+++ b/profiles/arch/arm/use.stable.mask
@@ -4,6 +4,10 @@
# This file requires eapi 5 or later. New entries go on top.
# Please use the same syntax as in use.mask
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary mask to support stable bug 639476
+ruby_targets_ruby23
+
# Brian Evans <grknight@gentoo.org> (16 Dec 2017)
# Needs dev-lang/php:7.1 stable
php_targets_php7-1
diff --git a/profiles/arch/hppa/make.defaults b/profiles/arch/hppa/make.defaults
index 0a3820884b6..3939be39232 100644
--- a/profiles/arch/hppa/make.defaults
+++ b/profiles/arch/hppa/make.defaults
@@ -24,3 +24,7 @@ CHOST_hppa="${CHOST}"
# 2006/08/18 - Donnie Berkholz <dberkholz@gentoo.org>
# Defaults for video drivers
VIDEO_CARDS="fbdev"
+
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary entry to support stable bug 639476
+RUBY_TARGETS="ruby22"
diff --git a/profiles/arch/hppa/use.stable.mask b/profiles/arch/hppa/use.stable.mask
index 12f7464923e..10be280ba22 100644
--- a/profiles/arch/hppa/use.stable.mask
+++ b/profiles/arch/hppa/use.stable.mask
@@ -4,6 +4,10 @@
# This file requires eapi 5 or later. New entries go on top.
# Please use the same syntax as in use.mask
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary mask to support stable bug 639476
+ruby_targets_ruby23
+
# Andreas Sturmlechner <asturm@gentoo.org> (20 Jan 2018)
# Mask boost for stabilisation timeout, bug #624662
boost
diff --git a/profiles/arch/ia64/make.defaults b/profiles/arch/ia64/make.defaults
index 476c229a5a6..c1552b0f8c8 100644
--- a/profiles/arch/ia64/make.defaults
+++ b/profiles/arch/ia64/make.defaults
@@ -26,3 +26,7 @@ VIDEO_CARDS="fbdev glint mach64 mga nv r128 radeon savage tdfx vesa voodoo"
# 2006/12/23 - Diego Pettenò <flameeyes@gentoo.org>
# Defaults for audio drivers - Took from x86 profile
ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
+
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary entry to support stable bug 639476
+RUBY_TARGETS="ruby22"
diff --git a/profiles/arch/ia64/use.stable.mask b/profiles/arch/ia64/use.stable.mask
index 88f33d5ae7b..3b65e3358e3 100644
--- a/profiles/arch/ia64/use.stable.mask
+++ b/profiles/arch/ia64/use.stable.mask
@@ -4,6 +4,10 @@
# This file requires eapi 5 or later. New entries go on top.
# Please use the same syntax as in use.mask
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary mask to support stable bug 639476
+ruby_targets_ruby23
+
# Not stable
mkl
diff --git a/profiles/arch/powerpc/ppc32/make.defaults b/profiles/arch/powerpc/ppc32/make.defaults
index 57c5d7770ef..80789f6ad54 100644
--- a/profiles/arch/powerpc/ppc32/make.defaults
+++ b/profiles/arch/powerpc/ppc32/make.defaults
@@ -35,3 +35,7 @@ IUSE_IMPLICIT="abi_ppc_32"
# Enable abi_ppc_32 for packages that don't have it forced.
ABI_PPC="32"
+
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary entry to support stable bug 639476
+RUBY_TARGETS="ruby22"
diff --git a/profiles/arch/powerpc/ppc32/use.stable.mask b/profiles/arch/powerpc/ppc32/use.stable.mask
index ab73cb222f1..8508553c1a8 100644
--- a/profiles/arch/powerpc/ppc32/use.stable.mask
+++ b/profiles/arch/powerpc/ppc32/use.stable.mask
@@ -1,3 +1,7 @@
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary mask to support stable bug 639476
+ruby_targets_ruby23
+
# Andrey Grozin <grozin@gentoo.org> (25 Jun 2014)
# no stable versions on ppc
clisp
diff --git a/profiles/arch/powerpc/ppc64/make.defaults b/profiles/arch/powerpc/ppc64/make.defaults
index fe54e02e4ef..6ea71879630 100644
--- a/profiles/arch/powerpc/ppc64/make.defaults
+++ b/profiles/arch/powerpc/ppc64/make.defaults
@@ -39,3 +39,7 @@ VIDEO_CARDS="fbdev mach64 mga nv r128 radeon vesa"
# Enable abi_ppc_64 for packages that don't have it forced.
ABI_PPC="64"
+
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary entry to support stable bug 639476
+RUBY_TARGETS="ruby22"
diff --git a/profiles/arch/powerpc/ppc64/use.stable.mask b/profiles/arch/powerpc/ppc64/use.stable.mask
index e797af411b7..fe877c3e26a 100644
--- a/profiles/arch/powerpc/ppc64/use.stable.mask
+++ b/profiles/arch/powerpc/ppc64/use.stable.mask
@@ -3,3 +3,7 @@
# This file requires eapi 5 or later. New entries go on top.
# Please use the same syntax as in use.mask
+
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary mask to support stable bug 639476
+ruby_targets_ruby23
diff --git a/profiles/arch/sparc/make.defaults b/profiles/arch/sparc/make.defaults
index 0053c3734d9..acad3dcea1e 100644
--- a/profiles/arch/sparc/make.defaults
+++ b/profiles/arch/sparc/make.defaults
@@ -39,3 +39,7 @@ MULTILIB_STRICT_DIRS="/lib32 /usr/lib32 /usr/kde/*/lib32 /usr/qt/*/lib32 /usr/X1
# Defaults for video drivers
VIDEO_CARDS="fbdev glint mach64 mga r128 radeon sunbw2 suncg14 suncg3 \
suncg6 sunffb sunleo tdfx voodoo"
+
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary entry to support stable bug 639476
+RUBY_TARGETS="ruby22"
diff --git a/profiles/arch/sparc/use.stable.mask b/profiles/arch/sparc/use.stable.mask
index a381058c68d..33c7089f46f 100644
--- a/profiles/arch/sparc/use.stable.mask
+++ b/profiles/arch/sparc/use.stable.mask
@@ -4,6 +4,10 @@
# This file requires eapi 5 or later. New entries go on top.
# Please use the same syntax as in use.mask
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary mask to support stable bug 639476
+ruby_targets_ruby23
+
# Hans de Graaff <graaff@gentoo.org> (13 Aug 2017)
# Drop stable ruby on sparc
ruby
diff --git a/profiles/arch/x86/make.defaults b/profiles/arch/x86/make.defaults
index f3347ce31a7..2e9b5fa264c 100644
--- a/profiles/arch/x86/make.defaults
+++ b/profiles/arch/x86/make.defaults
@@ -42,3 +42,7 @@ IUSE_IMPLICIT="abi_x86_32"
# Michał Górny <mgorny@gentoo.org> (01 Jul 2014)
# Default to abi_x86_32 for packages that don't have it forced.
ABI_X86="32"
+
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary entry to support stable bug 639476
+RUBY_TARGETS="ruby22"
diff --git a/profiles/arch/x86/use.stable.mask b/profiles/arch/x86/use.stable.mask
index 118c3436da9..6639125e6f2 100644
--- a/profiles/arch/x86/use.stable.mask
+++ b/profiles/arch/x86/use.stable.mask
@@ -4,6 +4,10 @@
# This file requires eapi 5 or later. New entries go on top.
# Please use the same syntax as in use.mask
+# Hans de Graaff <graaff@gentoo.org> (21 Jan 2018)
+# Temporary mask to support stable bug 639476
+ruby_targets_ruby23
+
# Michael Palimaka <kensington@gentoo.org> (03 Jun 2017)
# Not yet stable.
elogind