summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-05-07 07:23:49 +0200
committerHans de Graaff <graaff@gentoo.org>2021-05-07 07:26:53 +0200
commitd248eee727ec3568f9c53958796aab4a70946ac8 (patch)
tree42f3a671dcca001ad1eddf23e698df13b102c8e5
parentprofiles/arch/powerpc/ppc64: mask >=nodejs-16 (diff)
downloadgentoo-d248eee727ec3568f9c53958796aab4a70946ac8.tar.gz
gentoo-d248eee727ec3568f9c53958796aab4a70946ac8.tar.bz2
gentoo-d248eee727ec3568f9c53958796aab4a70946ac8.zip
dev-ruby/activesupport: Add 5.2.6
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-5.2.6.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 0e1cdef6aedd..5a7d7a6d38e6 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -1,4 +1,5 @@
DIST rails-5.2.4.5.tgz 8826076 BLAKE2B 41a13708f72f0c281af7b6c97828d873b9431913315e155bec2f798b83a9fd214a0176a93ba74d96b48718dc900b6737a62f5d6593ef7f5bb0b8430c96e5e234 SHA512 452e0649638daf57e8f7c6131bb048c0d960e875fbc3596678404965fd1438a5151858b22c2441a927509337b6a256671b53c24ee35ff477e18153af358b08af
+DIST rails-5.2.6.tgz 8841270 BLAKE2B 8e813f376446ef249aa3b48934d3cb5ae125c09c54353cc93557c3bee4f23e47ae7ceffab75d5cbfb691daed85149d9054337b468a0010bc5c7ebb879502396b SHA512 465e017591a9962a2e0dec2eac9669d5f507d0904e9eec50fbc8848d804ba5f1eb3220fd5acc949845f048f59cfc5e43f099707650edf301d6595e70e33888c7
DIST rails-6.0.3.5.tgz 18566999 BLAKE2B b07d1d6c1e2ebaaf3c337350bb08fe339e324818543dcd7163fe3c7ff56f50c5556f369badeb4fd48afa6d95449e18e57fa1b05db6ce544d38ee2f58bd3aa513 SHA512 c9d6bf689aeb40fb728fb681b65c48ebd51de893060ddac37a1fdefbb0d420cee3a456f148d96d577c651c9d7b994efdb3319fa865cb012af8712052a20a0bf3
DIST rails-6.0.3.7.tgz 18570545 BLAKE2B 6433705f18075e286d14d25dd87def61a3ac9c7a8fc5160f37b9a6f6ab0d7f36a7235602713888df45e55cf4afb56f922c476989304397d422016dc34f147353 SHA512 91612223c9461731741c056a700879ce274a177737fd19ed6341ce07acfa4e4862728ef12bfa1a70cdb3e5c8492ad0da6aae2e7d0ed5ad32d680d8bd8c3ab102
DIST rails-6.1.2.1.tgz 10990239 BLAKE2B ff1c9781eab32fda320cb2b9efc92e52ed155b659a43385781bfa422d03653879367bedc7ef4e3accb0a51b7962054eecd5202fd1e1a49ff7946c2f9388a69df SHA512 61e8bf0568c0b06a2c8f6c5e4ae6becc521646a5cdd3d6832c3b52998326a4bd437ad2bd284c010d445a3dc54bf519f7fbd2e9d4368c91b7d2a9abe46e3a276d
diff --git a/dev-ruby/activesupport/activesupport-5.2.6.ebuild b/dev-ruby/activesupport/activesupport-5.2.6.ebuild
new file mode 100644
index 000000000000..f76d75f297b6
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-5.2.6.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="MT_NO_PLUGINS=true"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ dev-ruby/i18n:1
+ >=dev-ruby/tzinfo-1.1:1
+ >=dev-ruby/minitest-5.1:5"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.0.5:3
+ dev-ruby/rack
+ dev-ruby/mocha
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|redis\|sqlite\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"; gem "rack"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+ sed -i -e '1igem "tzinfo", "~> 1.1"' test/abstract_unit.rb || die
+
+ # Avoid test that depends on timezone
+ sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions.
+ rm -f test/evented_file_update_checker_test.rb || die
+
+ # Avoid test that generates filename that is too long
+ sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die
+
+ # Avoid tests requiring a live redis running
+ rm -f test/cache/stores/redis_cache_store_test.rb || die
+ sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
+}