summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-15 12:24:56 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-15 13:17:15 +0100
commitd2e30b162862d3868d227e5e4774f373439d750e (patch)
tree200d999eeb8d6e9a80a25b3371f8bf74f0f004f9
parentsys-devel/llvm: release candidate bump (diff)
downloadgentoo-d2e30b162862d3868d227e5e4774f373439d750e.tar.gz
gentoo-d2e30b162862d3868d227e5e4774f373439d750e.tar.bz2
gentoo-d2e30b162862d3868d227e5e4774f373439d750e.zip
media-video/ffmpeg: do not build doc for non-native abis; they are overwritten when installed anyway.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index c6c909c76f6f..830fa7780e32 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -63,7 +63,7 @@ fi
# or $(use_enable foo foo) if no :bar is set.
# foo is added to IUSE.
FFMPEG_FLAG_MAP=(
- +bzip2:bzlib cpudetection:runtime-cpudetect debug doc gcrypt gnutls gmp
+ +bzip2:bzlib cpudetection:runtime-cpudetect debug gcrypt gnutls gmp
+gpl +hardcoded-tables +iconv lzma +network openssl +postproc
samba:libsmbclient sdl:ffplay sdl vaapi vdpau X:xlib xcb:libxcb
xcb:libxcb-shm xcb:libxcb-xfixes +zlib
@@ -97,7 +97,7 @@ FFMPEG_ENCODER_FLAG_MAP=(
)
IUSE="
- alsa +encode examples jack libressl oss pic static-libs test v4l
+ alsa doc +encode examples jack libressl oss pic static-libs test v4l
${FFMPEG_FLAG_MAP[@]%:*}
${FFMPEG_ENCODER_FLAG_MAP[@]%:*}
"
@@ -410,6 +410,9 @@ multilib_src_configure() {
esac
fi
+ # doc
+ myconf+=( $(multilib_native_use_enable doc) )
+
set -- "${S}/configure" \
--prefix="${EPREFIX}/usr" \
--libdir="${EPREFIX}/usr/$(get_libdir)" \