summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-02-09 21:00:30 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-02-09 21:02:04 -0600
commitd2f29f130f7cdc8e9cf684bfba853c072bf3d329 (patch)
tree97ddbaaa98aa68d938c4d1d6c2517b307ad221a9
parentapp-crypt/certbot: 1.23.0 bump (diff)
downloadgentoo-d2f29f130f7cdc8e9cf684bfba853c072bf3d329.tar.gz
gentoo-d2f29f130f7cdc8e9cf684bfba853c072bf3d329.tar.bz2
gentoo-d2f29f130f7cdc8e9cf684bfba853c072bf3d329.zip
app-crypt/certbot-apache: 1.23.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/certbot-apache/Manifest1
-rw-r--r--app-crypt/certbot-apache/certbot-apache-1.23.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index aef8f03379a4..e6e554036048 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1 +1,2 @@
DIST certbot-1.22.0.tar.gz 1352714 BLAKE2B 213dc08d3a88e0d20d6324c026a47eb96b9e45fbde41f79e37c2e62c655d7c6df01292e110d2e78ea085dfc62ef3c7b623279224029c9ae2a59e69c5c00054a5 SHA512 9a7a0d11e9fd5bd59b526a2cc5d0029b972e34a2bf41035c2d8ab535b93fc6d985ee8ea3dd5e50a7f4af80450135b739d1297245ad21b47b8362cddb03738932
+DIST certbot-1.23.0.tar.gz 1361107 BLAKE2B a1b1e029436eb32840d56ca815478df3774a30b69552c5f7a4ca18b054a49c8ce342fe7f7ffecfb6c0fb93338bb722d57e4537e1f142ab162bb8208575ee34be SHA512 bb64139c6406e7c87571beb94d435e079368cbb249d96b522dab72a9529b3a825f9258aac70c5a582d58117c700da281fb43ed8369f40a236c0b7e6acb5237b0
diff --git a/app-crypt/certbot-apache/certbot-apache-1.23.0.ebuild b/app-crypt/certbot-apache/certbot-apache-1.23.0.ebuild
new file mode 100644
index 000000000000..cf0c9621b1ae
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-1.23.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest