summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-04-20 18:59:42 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-04-20 19:00:34 -0400
commitd2fb79b419c1da51746a75a5f55e8b10a7993673 (patch)
tree08c1a99ea682b0348bc88a302dad2bda14724a74
parentwww-client/google-chrome: automated update (diff)
downloadgentoo-d2fb79b419c1da51746a75a5f55e8b10a7993673.tar.gz
gentoo-d2fb79b419c1da51746a75a5f55e8b10a7993673.tar.bz2
gentoo-d2fb79b419c1da51746a75a5f55e8b10a7993673.zip
sys-devel/m4: fix spawn_h.m4 for uclibc, bug #580688
Package-Manager: portage-2.2.26
-rw-r--r--sys-devel/m4/files/m4-1.4.17-fix-spawn_h_m4.patch31
-rw-r--r--sys-devel/m4/m4-1.4.17.ebuild8
2 files changed, 37 insertions, 2 deletions
diff --git a/sys-devel/m4/files/m4-1.4.17-fix-spawn_h_m4.patch b/sys-devel/m4/files/m4-1.4.17-fix-spawn_h_m4.patch
new file mode 100644
index 000000000000..dbbac65466c7
--- /dev/null
+++ b/sys-devel/m4/files/m4-1.4.17-fix-spawn_h_m4.patch
@@ -0,0 +1,31 @@
+commit d6eab2e70fc5ccc82a73e5c988b76a229e4cd3d5
+Author: Pádraig Brady <P@draigBrady.com>
+Date: Tue Jan 14 16:59:07 2014 +0000
+
+ spawn: fix link error on uclibc
+
+ * m4/spawn_h.m4 (gl_HAVE_POSIX_SPAWN): use AC_SEARCH_LIBS,
+ to incorporate -lrt if needed (on uclibc for example).
+ * modules/posix_spawn: Reference the substituted LIB.
+
+diff --git a/m4/spawn_h.m4 b/m4/spawn_h.m4
+index 87fe122..3eb835c 100644
+--- a/m4/spawn_h.m4
++++ b/m4/spawn_h.m4
+@@ -64,7 +64,15 @@ AC_DEFUN([gl_HAVE_POSIX_SPAWN],
+ dnl once only, before all statements that occur in other macros.
+ AC_REQUIRE([gl_SPAWN_H_DEFAULTS])
+
+- AC_CHECK_FUNCS_ONCE([posix_spawn])
++ LIB_POSIX_SPAWN=
++ AC_SUBST([LIB_POSIX_SPAWN])
++ gl_saved_libs=$LIBS
++ AC_SEARCH_LIBS([posix_spawn], [rt],
++ [test "$ac_cv_search_posix_spawn" = "none required" ||
++ LIB_POSIX_SPAWN=$ac_cv_search_posix_spawn])
++ AC_CHECK_FUNCS([posix_spawn])
++ LIBS=$gl_saved_libs
++
+ if test $ac_cv_func_posix_spawn != yes; then
+ HAVE_POSIX_SPAWN=0
+ fi
diff --git a/sys-devel/m4/m4-1.4.17.ebuild b/sys-devel/m4/m4-1.4.17.ebuild
index 3e45c8c98c18..b28aa1804602 100644
--- a/sys-devel/m4/m4-1.4.17.ebuild
+++ b/sys-devel/m4/m4-1.4.17.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
+
+inherit eutils
DESCRIPTION="GNU macro processor"
HOMEPAGE="https://www.gnu.org/software/m4/m4.html"
@@ -18,6 +20,8 @@ DEPEND="app-arch/xz-utils"
RDEPEND=""
src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-spawn_h_m4.patch #580688
+
# Disable gnulib build test that has no impact on the source.
# Re-enable w/next version bump (and gnulib is updated). #554728
[[ ${PV} != "1.4.17" ]] && die "re-enable test #554728"