summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-23 09:10:30 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-23 09:28:55 +0100
commitd35a82e675a3320ed3a1858bdecb0117a3a2feb3 (patch)
tree2c49b615d32849d5c9e592846bed6873f52f6746
parentdev-python/botocore: Bump to 1.19.42 (diff)
downloadgentoo-d35a82e675a3320ed3a1858bdecb0117a3a2feb3.tar.gz
gentoo-d35a82e675a3320ed3a1858bdecb0117a3a2feb3.tar.bz2
gentoo-d35a82e675a3320ed3a1858bdecb0117a3a2feb3.zip
dev-python/boto3: Bump to 1.16.42
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.16.42.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index dc4e576d3d77..d618baa08b08 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.16.30.tar.gz 340801 BLAKE2B fcf87b43d2c18ecf1e9d7f0c8c423143e44777a
DIST boto3-1.16.36.tar.gz 341458 BLAKE2B 7e4cf667cd59caa8433226eb6914412370bfa4c002f6f5d992fe49c93528d59d5740de6c8782af71d94461ea704a36d8ed46ccadfbf83982504ab507aab9b058 SHA512 06d9c6e721d1ab529e6a598b14ba6f740bec32a8165582853149b9aa294f0a272d0da4222f0dc7ef83055d91b4b0a0176e65bb34784990aca43e44db43650a2d
DIST boto3-1.16.40.tar.gz 342028 BLAKE2B 6728b658ee75b76d4885e43316a58508a8563476a85af39462adf58982bfd75a680b05d273a5a0aabd3c935cd87f72d93ffd815d7230b9f44d64337f66de5071 SHA512 4ebe3069fd93657165acd7bab40c44fb37de61326e103b9675f919a0f88ef20341c9efd6fe05684a13e26f10d5b18858a978bbb04225af628df6ff16ad8ab071
DIST boto3-1.16.41.tar.gz 342352 BLAKE2B 601384979c792a2e1871bd3837ca2a56e411d0f50ee2766bde33f8be1b0e1fa4078bd731b002008d98efc5ef6d2893ec3811238d45f1f6e22ba4904972aa960e SHA512 c80727d2788603db8d46e1ec9c766341a875b7768cfeb86425b784141c8854f314fcb2de1618203971eac3734f64b26523e268f4ca2039f513f9ea6a218ab8be
+DIST boto3-1.16.42.tar.gz 342384 BLAKE2B c966fb6bb645bfa513b30bc72592eab404954c2816d4e2e533af8c0753941f07b8228201f17077d252086a2d2167ef31ba11abe6154500b125ee74a1e6d3218a SHA512 0316179c0acd1afe798c3b54bfc7cde5ac3082e6747228619a72b805ae3b2a56311cdcde54ca2afa49ee62c3554b986ff2986c60ba7b5cbdad570a329b6371fb
diff --git a/dev-python/boto3/boto3-1.16.42.ebuild b/dev-python/boto3/boto3-1.16.42.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.16.42.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}