summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-14 21:21:04 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-14 23:40:20 +0200
commitd3c0d60035f05aeab5deb9664af919e845150fd9 (patch)
treeb4babc80f0f8aa8563ec74779914ebca478935b3
parentdev-python/boto3: Bump to 1.17.111 (diff)
downloadgentoo-d3c0d60035f05aeab5deb9664af919e845150fd9.tar.gz
gentoo-d3c0d60035f05aeab5deb9664af919e845150fd9.tar.bz2
gentoo-d3c0d60035f05aeab5deb9664af919e845150fd9.zip
app-admin/awscli: Bump to 1.19.111
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.19.111.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 46100502813d..1643670bba4f 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,4 +5,5 @@ DIST awscli-1.19.107.tar.gz 2025880 BLAKE2B bbb307072a63a9722496aaae52c2f9fbc274
DIST awscli-1.19.108.tar.gz 2026311 BLAKE2B 7404fb3010fa122bf210133667696df0e83c0c5d5adc717b75995cd95077f4ebcdd53375e687dce7d52eb1ef264110302f049897c18b7856be9d5e5a24f50ff3 SHA512 f061de7c7cc926f3fc5dc41a33068c8d575e1027f50099c148e80b5be55497508b44b11821e7f675e73bbcbfef12539e4d73afcd6a849d6ad7fc4f72b857b4d7
DIST awscli-1.19.109.tar.gz 2026658 BLAKE2B 3ec642d44057795519e9e94ce73a6b26b42976018355f029ad7ec5fd6515497c725aad5872b3e061ff15cb7263823577bb3dfd1f43c3f1617ee996c982e722b0 SHA512 71c419359a12b159b06a7f769dbaaea8d5be0de4b71fb002bf3dd4c26810354038fc1057155235b26ad43b3af258e141c139cc84654e11650aa33d013381a192
DIST awscli-1.19.110.tar.gz 2026742 BLAKE2B 6f45530050d234125a806bc2be48ba8d9c46db0a4180cf62ff4cfc9352d1ed118b82bcb814df91afb3ef1065fd1d6549ef2cd8b54775890b9bf52a472e91cedc SHA512 f5fc4e0d8ff8fa91c5e5ea95a79e84fa6de5d5ba0a12e9e2c29e6703cddf4bb63a1e501d9fc1e46945ea79e1980c95c68d959dde66edb89d63e9b9984994804d
+DIST awscli-1.19.111.tar.gz 2027361 BLAKE2B 8d7efd009483fe897719d1dae50a5e67e8bb4b76ccf1f3dad7632905a7e0fa15382d55275d0a371aeeefadb47204a635ad255660fc134af827d8bb0c39cf0130 SHA512 0faeb58a761ac7ebbef383bf38d28ffd8a2735b0f2a101f4100f1b302ce1df4848f851d3bdfbb1eb2b95ebaed5144d42c3a728528f3ea3c65150fbea071fc9d3
DIST awscli-1.19.97.tar.gz 2020143 BLAKE2B 2dac6f59a04a958b09e0f8b7d056583015762df78ed1349b55c6301d3189e1100bd8ab98445ded3ccc0ddbf1148ddf0475086704f123b0db1ccfd1cacb6b4680 SHA512 4e4e0f34ba02819232427f7571a4b10d22b167788d758c9ac43749607ea7a4c498259fcc5c69fb32d66faffc535a5b3045006168b64506f2b0f9fbbaa804e387
diff --git a/app-admin/awscli/awscli-1.19.111.ebuild b/app-admin/awscli/awscli-1.19.111.ebuild
new file mode 100644
index 000000000000..ff429f8d3a3e
--- /dev/null
+++ b/app-admin/awscli/awscli-1.19.111.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install nose
+
+PATCHES=(
+ "${FILESDIR}"/awscli-1.19.47-py39.patch
+)
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ nosetests -v tests/{functional,unit} ||
+ die "Tests failed for ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}