summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBratishkaErik <bratishkaerik@getgoogleoff.me>2022-03-24 19:43:14 +0600
committerFlorian Schmaus <flow@gentoo.org>2022-03-28 09:49:42 +0200
commitd3e007705a1dbe686551fba460f2294285043db0 (patch)
tree5991abc113144e791127c3c544a263a878ff1451
parentdev-lang/zig: drop old version (diff)
downloadgentoo-d3e007705a1dbe686551fba460f2294285043db0.tar.gz
gentoo-d3e007705a1dbe686551fba460f2294285043db0.tar.bz2
gentoo-d3e007705a1dbe686551fba460f2294285043db0.zip
dev-lang/zig: add memory requirement via check-reqs
see https://github.com/ziglang/zig/issues/6485 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: BratishkaErik <bratishkaerik@getgoogleoff.me> Closes: https://github.com/gentoo/gentoo/pull/24734 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-lang/zig/zig-0.7.1.ebuild9
-rw-r--r--dev-lang/zig/zig-0.8.1-r1.ebuild9
-rw-r--r--dev-lang/zig/zig-0.9.1.ebuild7
-rw-r--r--dev-lang/zig/zig-9999.ebuild11
4 files changed, 24 insertions, 12 deletions
diff --git a/dev-lang/zig/zig-0.7.1.ebuild b/dev-lang/zig/zig-0.7.1.ebuild
index d775cde187a1..39cf045b3b38 100644
--- a/dev-lang/zig/zig-0.7.1.ebuild
+++ b/dev-lang/zig/zig-0.7.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake llvm
+inherit cmake llvm check-reqs
DESCRIPTION="A robust, optimal, and maintainable programming language"
HOMEPAGE="https://ziglang.org/"
@@ -46,6 +46,9 @@ llvm_check_deps() {
has_version "sys-devel/clang:${LLVM_SLOT}"
}
+# see https://github.com/ziglang/zig/wiki/Troubleshooting-Build-Issues#high-memory-requirements
+CHECKREQS_MEMORY="6G"
+
src_configure() {
local mycmakeargs=(
-DZIG_USE_CCACHE=OFF
diff --git a/dev-lang/zig/zig-0.8.1-r1.ebuild b/dev-lang/zig/zig-0.8.1-r1.ebuild
index 659a2ac1dbca..86befea8144c 100644
--- a/dev-lang/zig/zig-0.8.1-r1.ebuild
+++ b/dev-lang/zig/zig-0.8.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake llvm
+inherit cmake llvm check-reqs
DESCRIPTION="A robust, optimal, and maintainable programming language"
HOMEPAGE="https://ziglang.org/"
@@ -45,6 +45,9 @@ llvm_check_deps() {
has_version "sys-devel/clang:${LLVM_SLOT}"
}
+# see https://github.com/ziglang/zig/wiki/Troubleshooting-Build-Issues#high-memory-requirements
+CHECKREQS_MEMORY="10G"
+
src_configure() {
local mycmakeargs=(
-DZIG_USE_CCACHE=OFF
diff --git a/dev-lang/zig/zig-0.9.1.ebuild b/dev-lang/zig/zig-0.9.1.ebuild
index f3e935ec2f28..30aa4b234c28 100644
--- a/dev-lang/zig/zig-0.9.1.ebuild
+++ b/dev-lang/zig/zig-0.9.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
LLVM_MAX_SLOT=13
-inherit cmake llvm
+inherit cmake llvm check-reqs
DESCRIPTION="A robust, optimal, and maintainable programming language"
HOMEPAGE="https://ziglang.org/"
@@ -44,6 +44,9 @@ llvm_check_deps() {
has_version "sys-devel/clang:${LLVM_SLOT}"
}
+# see https://github.com/ziglang/zig/wiki/Troubleshooting-Build-Issues#high-memory-requirements
+CHECKREQS_MEMORY="10G"
+
src_configure() {
local mycmakeargs=(
-DZIG_USE_CCACHE=OFF
diff --git a/dev-lang/zig/zig-9999.ebuild b/dev-lang/zig/zig-9999.ebuild
index ca45b1e7e4dc..30aa4b234c28 100644
--- a/dev-lang/zig/zig-9999.ebuild
+++ b/dev-lang/zig/zig-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
LLVM_MAX_SLOT=13
-inherit cmake llvm
+inherit cmake llvm check-reqs
DESCRIPTION="A robust, optimal, and maintainable programming language"
HOMEPAGE="https://ziglang.org/"
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
else
SRC_URI="https://github.com/ziglang/zig/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64"
+ KEYWORDS="~amd64 ~arm ~arm64"
fi
LICENSE="MIT"
@@ -44,6 +44,9 @@ llvm_check_deps() {
has_version "sys-devel/clang:${LLVM_SLOT}"
}
+# see https://github.com/ziglang/zig/wiki/Troubleshooting-Build-Issues#high-memory-requirements
+CHECKREQS_MEMORY="10G"
+
src_configure() {
local mycmakeargs=(
-DZIG_USE_CCACHE=OFF