summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-01-31 18:05:26 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-02-01 04:28:20 +1100
commitd44dfcaf2545c50c28ed4c066efbbc912de643da (patch)
tree62b780686c6bf1148e0fefdc0374afdfeeeb905d
parentnet-ftp/yafc: remove proxied maintainer at their request (diff)
downloadgentoo-d44dfcaf.tar.gz
gentoo-d44dfcaf.tar.bz2
gentoo-d44dfcaf.zip
media-gfx/nomacs: Fix configure with >=opencv-3
Package-Manager: portage-2.2.27
-rw-r--r--media-gfx/nomacs/files/nomacs-3.0.0-opencv3.patch21
-rw-r--r--media-gfx/nomacs/nomacs-2.4.2.ebuild7
-rw-r--r--media-gfx/nomacs/nomacs-2.4.4.ebuild4
-rw-r--r--media-gfx/nomacs/nomacs-2.4.6.ebuild4
-rw-r--r--media-gfx/nomacs/nomacs-3.0.0.ebuild1
5 files changed, 33 insertions, 4 deletions
diff --git a/media-gfx/nomacs/files/nomacs-3.0.0-opencv3.patch b/media-gfx/nomacs/files/nomacs-3.0.0-opencv3.patch
new file mode 100644
index 000000000000..a13d90fe2d17
--- /dev/null
+++ b/media-gfx/nomacs/files/nomacs-3.0.0-opencv3.patch
@@ -0,0 +1,21 @@
+commit aa3fffc15bb6cbec8ef140a070dc12e6888e79df
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun Jan 31 17:38:21 2016 +0100
+
+ Drop minimum OpenCV version messing with detection of >=3.0.0
+
+ Similar to commit 624a2fa7fba25a9432dc15031f3fd569367927bd
+
+diff --git a/ImageLounge/cmake/Unix.cmake b/ImageLounge/cmake/Unix.cmake
+index 4e91135..e9ec436 100644
+--- a/ImageLounge/cmake/Unix.cmake
++++ b/ImageLounge/cmake/Unix.cmake
+@@ -43,7 +43,7 @@ endif(NOT EXIV2_FOUND)
+ # search for opencv
+ unset(OpenCV_FOUND CACHE)
+ if(ENABLE_OPENCV)
+- find_package(OpenCV 2.1.0 REQUIRED core imgproc)
++ find_package(OpenCV REQUIRED core imgproc)
+ if (NOT OpenCV_LIBRARIES) # OpenCV_FOUND can not be used since it is set in Ubuntu 12.04 (without finding opencv)
+ # Older OpenCV versions only supplied pkg-config files
+ if(PKG_CONFIG_FOUND)
diff --git a/media-gfx/nomacs/nomacs-2.4.2.ebuild b/media-gfx/nomacs/nomacs-2.4.2.ebuild
index b3ef73bdc759..f666011ebc78 100644
--- a/media-gfx/nomacs/nomacs-2.4.2.ebuild
+++ b/media-gfx/nomacs/nomacs-2.4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -31,7 +31,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
-PATCHES=( "${FILESDIR}/${P}-include.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-include.patch"
+ "${FILESDIR}/${PN}-3.0.0-opencv3.patch"
+)
src_configure() {
local mycmakeargs=(
diff --git a/media-gfx/nomacs/nomacs-2.4.4.ebuild b/media-gfx/nomacs/nomacs-2.4.4.ebuild
index dee2bc0a009b..d267681f4fc6 100644
--- a/media-gfx/nomacs/nomacs-2.4.4.ebuild
+++ b/media-gfx/nomacs/nomacs-2.4.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -34,6 +34,8 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+PATCHES=( "${FILESDIR}/${PN}-3.0.0-opencv3.patch" )
+
src_configure() {
local mycmakeargs=(
-DENABLE_QT5=OFF
diff --git a/media-gfx/nomacs/nomacs-2.4.6.ebuild b/media-gfx/nomacs/nomacs-2.4.6.ebuild
index 01cf47ad35d2..ecda8a17d14d 100644
--- a/media-gfx/nomacs/nomacs-2.4.6.ebuild
+++ b/media-gfx/nomacs/nomacs-2.4.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -47,6 +47,8 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+PATCHES=( "${FILESDIR}/${PN}-3.0.0-opencv3.patch" )
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_enable opencv)
diff --git a/media-gfx/nomacs/nomacs-3.0.0.ebuild b/media-gfx/nomacs/nomacs-3.0.0.ebuild
index 67552f9e5438..3915d6dc5b15 100644
--- a/media-gfx/nomacs/nomacs-3.0.0.ebuild
+++ b/media-gfx/nomacs/nomacs-3.0.0.ebuild
@@ -44,6 +44,7 @@ PATCHES=(
"${FILESDIR}/${P}-tiff-build.patch"
"${FILESDIR}/${P}-quazip-build.patch"
"${FILESDIR}/${P}-quazip-link.patch"
+ "${FILESDIR}/${P}-opencv3.patch"
)
src_configure() {