summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-31 15:57:30 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-31 15:57:50 +0100
commitd4931ad3ae7ed96249a4fef52dfb82b22d675577 (patch)
treef2ac780be61b91d2fc9580e3dfb86ac4fce329a8
parentsci-mathematics/form: bump to 4.2.1 (diff)
downloadgentoo-d4931ad3ae7ed96249a4fef52dfb82b22d675577.tar.gz
gentoo-d4931ad3ae7ed96249a4fef52dfb82b22d675577.tar.bz2
gentoo-d4931ad3ae7ed96249a4fef52dfb82b22d675577.zip
net-analyzer/portmon: Fix CFLAGS=-fno-common
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=707208 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-analyzer/portmon/files/portmon-2.0-fno-common.patch58
-rw-r--r--net-analyzer/portmon/portmon-2.0-r1.ebuild33
2 files changed, 91 insertions, 0 deletions
diff --git a/net-analyzer/portmon/files/portmon-2.0-fno-common.patch b/net-analyzer/portmon/files/portmon-2.0-fno-common.patch
new file mode 100644
index 000000000000..bfe6a914635e
--- /dev/null
+++ b/net-analyzer/portmon/files/portmon-2.0-fno-common.patch
@@ -0,0 +1,58 @@
+--- a/src/portmon.c
++++ b/src/portmon.c
+@@ -35,6 +35,15 @@
+ #include <getopt.h>
+ #endif
+
++int report_flag;
++int daemonize_flag;
++
++struct host_struct *hosts;
++char *err_msg;
++char logfile[STRLARGE];
++int timeout;
++int verbose;
++
+ void version(void)
+ {
+ printf("This is %s, version %s\n", PACKAGE, VERSION);
+--- a/src/portmon.h
++++ b/src/portmon.h
+@@ -31,8 +31,8 @@
+ #define STRLARGE 512
+
+ // flags
+-int report_flag;
+-int daemonize_flag;
++extern int report_flag;
++extern int daemonize_flag;
+
+ struct port
+ {
+@@ -43,7 +43,7 @@
+ };
+
+ // create an array of hosts
+-struct host_struct
++extern struct host_struct
+ {
+ char name[STRMED];
+ struct port ports[STRSMALL];
+@@ -52,13 +52,13 @@
+ *hosts;
+
+ // place to hold error messages
+-char *err_msg;
++extern char *err_msg;
+ // place we log crap
+-char logfile[STRLARGE];
++extern char logfile[STRLARGE];
+ // timeout (seconds)
+-int timeout;
++extern int timeout;
+ // verbose mode
+-int verbose;
++extern int verbose;
+
+ // Functions in various files
+
diff --git a/net-analyzer/portmon/portmon-2.0-r1.ebuild b/net-analyzer/portmon/portmon-2.0-r1.ebuild
new file mode 100644
index 000000000000..824a242bbd0c
--- /dev/null
+++ b/net-analyzer/portmon/portmon-2.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Portmon is a network service monitoring daemon"
+HOMEPAGE="http://aboleo.net/software/portmon/"
+SRC_URI="http://aboleo.net/software/portmon/downloads/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_configure() {
+ econf --sysconfdir=/etc/portmon
+}
+
+src_install() {
+ into /usr
+ dosbin src/portmon
+
+ doman extras/portmon.8
+
+ insinto /etc/portmon
+ doins extras/portmon.hosts.sample
+ dodoc AUTHORS BUGS README
+
+ newinitd "${FILESDIR}"/portmon.init portmon
+}