summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-09-27 13:25:17 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-09-27 13:27:27 +0300
commitd5c9c24950fe0779503a713d50abd705e830ba96 (patch)
treeb3802bb5dd2f311a519dddfc59fcb9beee86f4fa
parentmedia-libs/libavif: Add gdk-pixbuf use flag, add live ebuild (diff)
downloadgentoo-d5c9c24950fe0779503a713d50abd705e830ba96.tar.gz
gentoo-d5c9c24950fe0779503a713d50abd705e830ba96.tar.bz2
gentoo-d5c9c24950fe0779503a713d50abd705e830ba96.zip
sys-kernel/pf-sources: bump to 5.8-pf6
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.8_p6.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index 6ff10055dc95..1ea5cfb45ff8 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -15,3 +15,4 @@ DIST pf-sources-5.8_p2.patch 1071081 BLAKE2B e6c5f85607b7483ee711bee6b62dae5fc1d
DIST pf-sources-5.8_p3.patch 1248429 BLAKE2B acf0911cd8b9c356bcafe754e54e982a6f749800c01795fa9ca4573a932e366185378e41a649150718ddf604e787ba85d22bec134d106c2fb44aa35262a32d19 SHA512 01cb5fd69560220c61106508585db4970164dc27b373aee03b5b9a14a30af5b04534095b9f839228f5a9bf4139f8d6e0b8b978ca2ae1b6c1e873cce782c7e9c7
DIST pf-sources-5.8_p4.patch 1896149 BLAKE2B 1d036e1d4605372557e110d829edbfe03bbe76367b122c3081c04bdd13eb17d3c6076eebe674b957a31d8909170d0cd667692f37f14d47030f72687ccdbf38a5 SHA512 94c0a51973788a26a2130abbbda1bbcfcc8ca8f43ed8bdeed5ff27989baa886b5501b392c2aa90ce833d8b729c32fce55dced1c635e2388395967efff848d997
DIST pf-sources-5.8_p5.patch 2141177 BLAKE2B 5d55ced84a31fa86d80d2e9ff694812b073ee2799a0685455c83dda8de7bb5b9231d590673092e8b1b6301a3e87f8089c656879d323524c7f76d3eade9000bf2 SHA512 6b2948aee3bbfebc4e7b4c46ead91987f5b2690b91e7ffbeace2b78f6455555ef36f4557fd88c82cb302b5fe389d8e9d786a1ec4d2d226780357760dc6024970
+DIST pf-sources-5.8_p6.patch 2337599 BLAKE2B 8ea69321cc3d7d9b63d67823c5326e796f9d09e39b29cad9eb0500f025b9c7dad71a20bc8b702815fb1c3dad1846e63e95a916114901fc519a2f8df120d4ca3a SHA512 10ae0bcb7b99bcfd20153f037128f4fbd127a9196ef3f346a328fbd12df38ebb61987c577b7e8846f447ed4b6acd448a69f62bab9680b6bc381d8b48d670073b
diff --git a/sys-kernel/pf-sources/pf-sources-5.8_p6.ebuild b/sys-kernel/pf-sources/pf-sources-5.8_p6.ebuild
new file mode 100644
index 000000000000..d2e345cf5fb4
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.8_p6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux
+# updates
+K_GENPATCHES_VER="1"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+inherit optfeature kernel-2
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog "Optional features:"
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}