summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-01-15 05:13:02 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2018-01-15 05:36:33 -0500
commitd5e2aea57f0e218ee8601bdaa4965e5202b0e79a (patch)
tree13a8739b8636e64beeeb6a6cc72ddc41c2c2a767
parentdev-perl/Sub-Quote: keyworded 2.4.0 for ia64 (diff)
downloadgentoo-d5e2aea57f0e218ee8601bdaa4965e5202b0e79a.tar.gz
gentoo-d5e2aea57f0e218ee8601bdaa4965e5202b0e79a.tar.bz2
gentoo-d5e2aea57f0e218ee8601bdaa4965e5202b0e79a.zip
app-office/gnucash: Bump to 2.7.3
Read your news items! This introduces breaking changes in data schemas. Back up your data! No longer uses insecure net-libs/webkit-gtk. Bug: https://bugs.gentoo.org/629114 Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--app-office/gnucash/Manifest1
-rw-r--r--app-office/gnucash/files/gnucash-2.7.3-no-gtest-src.patch15
-rw-r--r--app-office/gnucash/gnucash-2.7.3.ebuild151
-rw-r--r--app-office/gnucash/metadata.xml2
4 files changed, 169 insertions, 0 deletions
diff --git a/app-office/gnucash/Manifest b/app-office/gnucash/Manifest
index d00db65c5a5e..f32abd8c0226 100644
--- a/app-office/gnucash/Manifest
+++ b/app-office/gnucash/Manifest
@@ -1,2 +1,3 @@
DIST gnucash-2.6.15.tar.bz2 13406483 BLAKE2B 927838c5c9c11a19eb9f8e11726825458d5b414f4ef24baf1a7ae15c33825eeed2fd87892e728b37c43385360fd06a60df0bade4244b5c93dac5522f09849c92 SHA512 6ec0652565025ac8281152ed64f2f820ecdb17ead5f17738728e094d116e638a08af57a46c0d5b59679f30f142ce372a5f61bd164f68f6b608d09de37cec38c6
DIST gnucash-2.6.19.tar.bz2 13612124 BLAKE2B cc66e4d7994274bb2ad97437333dbe62b0e9228e20e05e01fc7861bc45a8f07bc56d2a69850eda301d5e7f679d96a9d28c24c56a4860cff6727b66867482deae SHA512 0a979caf48ba96d6f37a929036e7172855cfb03af8832f479966bce72fad3400903925134d33aaa31eb6b36a2041f5e0d3f74b88e95b83c7d76e96b1503bec13
+DIST gnucash-2.7.3.tar.bz2 13736166 BLAKE2B 352c7bd9fe11b3b1b039acedb43be6f48960fac7ef6e4eaca5ca1ce944808d2d36c3a22b15b7150b8026bad10bfa0766fd19ac8d1b4f5f2cb2bcb8c112ee87bc SHA512 78c482eb3146406d561320866c480101cf35c51d8ab789e8d2688c7f7e16d1870b33feb7bcdb3cd8feaca300ce9bcf9fa05ba8e1804b221526d181763dcea611
diff --git a/app-office/gnucash/files/gnucash-2.7.3-no-gtest-src.patch b/app-office/gnucash/files/gnucash-2.7.3-no-gtest-src.patch
new file mode 100644
index 000000000000..66c1f9fec852
--- /dev/null
+++ b/app-office/gnucash/files/gnucash-2.7.3-no-gtest-src.patch
@@ -0,0 +1,15 @@
+Bug: https://bugs.gentoo.org/643566
+
+--- a/common/test-core/Makefile.am
++++ b/common/test-core/Makefile.am
+@@ -80,9 +80,9 @@
+ libgmock.a
+ nodist_libgtest_a_SOURCES = ${GTEST_SRC}/src/gtest-all.cc
+ libgtest_a_CPPFLAGS = ${AM_CPPFLAGS} -I${GTEST_HEADERS} -I${GTEST_SRC}
+-endif
+ nodist_libgmock_a_SOURCES = ${GMOCK_SRC_PATH}/gmock-all.cc
+ libgmock_a_CPPFLAGS = ${libgtest_a_CPPFLAGS} -I${GMOCK_HEADERS} -I${GMOCK_SRC}
++endif
+
+ gncscmmoddir = ${GNC_SCM_INSTALL_DIR}/gnucash
+ gncscmmod_DATA = unittest-support.scm
diff --git a/app-office/gnucash/gnucash-2.7.3.ebuild b/app-office/gnucash/gnucash-2.7.3.ebuild
new file mode 100644
index 000000000000..9bf87b6b7157
--- /dev/null
+++ b/app-office/gnucash/gnucash-2.7.3.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# We need to run eautoreconf to prevent linking against system libs,
+# this can be noticed, for example, when updating an old version
+# compiled against guile-1.8 to a newer one relying on 2.0
+# https://bugs.gentoo.org/show_bug.cgi?id=590536#c39
+# https://bugzilla.gnome.org/show_bug.cgi?id=775634
+GNOME2_EAUTORECONF="yes"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="A personal finance manager"
+HOMEPAGE="http://www.gnucash.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+# Add doc back in for 3.0 and bump app-doc/gnucash-docs
+IUSE="aqbanking chipcard debug gnome-keyring mysql nls ofx postgres python
+ quotes -register2 sqlite"
+REQUIRED_USE="
+ chipcard? ( aqbanking )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+# libdbi version requirement for sqlite taken from bug #455134
+#
+# dev-libs/boost must always be built with nls enabled.
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libxml2-2.7.0:2
+ >=dev-scheme/guile-2.0.0:12=[regex]
+ >=sys-libs/zlib-1.1.4
+ >=x11-libs/gtk+-3.14.0:3
+ dev-libs/boost:=[icu,nls]
+ dev-libs/icu:=
+ dev-libs/libxslt
+ gnome-base/dconf
+ net-libs/webkit-gtk:4=
+ aqbanking? (
+ >=net-libs/aqbanking-5[gtk,ofx?]
+ sys-libs/gwenhywfar[gtk]
+ chipcard? ( sys-libs/libchipcard )
+ )
+ gnome-keyring? ( >=app-crypt/libsecret-0.18 )
+ mysql? (
+ dev-db/libdbi
+ dev-db/libdbi-drivers[mysql]
+ )
+ ofx? ( >=dev-libs/libofx-0.9.1 )
+ postgres? (
+ dev-db/libdbi
+ dev-db/libdbi-drivers[postgres]
+ )
+ python? ( ${PYTHON_DEPS} )
+ quotes? (
+ >=dev-perl/Finance-Quote-1.11
+ dev-perl/Date-Manip
+ dev-perl/HTML-TableExtract
+ )
+ sqlite? (
+ >=dev-db/libdbi-0.9.0
+ >=dev-db/libdbi-drivers-0.9.0[sqlite]
+ )
+"
+
+DEPEND="${RDEPEND}
+ || (
+ >=dev-cpp/gtest-1.8.0
+ (
+ dev-cpp/gmock
+ dev-cpp/gtest
+ )
+ )
+ dev-lang/perl
+ dev-perl/XML-Parser
+ dev-util/intltool
+ gnome-base/gnome-common
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+
+# Uncomment for 3.0
+# PDEPEND="doc? (
+# ~app-doc/gnucash-docs-${PV}
+# gnome-extra/yelp
+# )"
+
+# Bug 643566: Conditional didn't enclose everything related to gtest source
+# files and they're not needed.
+PATCHES=( "${FILESDIR}"/gnucash-2.7.3-no-gtest-src.patch )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myconf
+
+ if use sqlite || use mysql || use postgres ; then
+ myconf+=" --enable-dbi"
+ else
+ myconf+=" --disable-dbi"
+ fi
+
+ # As of 2.7.3, the presence of --disable-register2 would enable register2 as
+ # well.
+ use register2 && myconf+=" --enable-register2"
+
+ gnome2_src_configure \
+ --disable-doxygen \
+ --disable-error-on-warning \
+ --disable-binreloc \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_enable gnome-keyring password-storage) \
+ $(use_enable aqbanking) \
+ $(use_enable ofx) \
+ $(use_enable python) \
+ ${myconf}
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ rm "${ED}"/usr/share/doc/${PF}/{COPYING,INSTALL,projects.html} || die
+ rm "${ED}"/usr/share/doc/${PF}/*win32-bin.txt || die
+
+ use aqbanking && dodoc doc/README.HBCI
+ use ofx && dodoc doc/README.OFX
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ ewarn "Backup all financial files or databases before using GnuCash >=2.7.0!"
+ ewarn
+ ewarn "GnuCash 2.7.0 introduced large changes in its file format and database"
+ ewarn "schema that WILL prevent you from reverting back to GnuCash 2.6."
+
+}
diff --git a/app-office/gnucash/metadata.xml b/app-office/gnucash/metadata.xml
index 97283552223d..4c84c7d43e6d 100644
--- a/app-office/gnucash/metadata.xml
+++ b/app-office/gnucash/metadata.xml
@@ -10,11 +10,13 @@
<name>Gentoo GNOME Desktop</name>
</maintainer>
<use>
+ <flag name="aqbanking">Connect to some internet banks via AqBanking</flag>
<flag name="chipcard">Enable support for chipcard reading and
processing.</flag>
<flag name="hbci">Enable HBCI support, for connecting to some internet
banks</flag>
<flag name="quotes">Enable Online Stock Quote retrieval</flag>
+ <flag name="register2">Use the new register (Experimental)</flag>
</use>
<upstream>
<remote-id type="sourceforge">gnucash</remote-id>