summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-10 22:43:58 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-11 00:03:21 +0200
commitd687a5bea74cfcceb0aa04d95783d7abad6df9cc (patch)
treef7232f0e55afb72cdf66c8fe1131eda6864217c1
parentx11-libs/gdk-pixbuf-loader-webp: Maintainer retired (diff)
downloadgentoo-d687a5bea74cfcceb0aa04d95783d7abad6df9cc.tar.gz
gentoo-d687a5bea74cfcceb0aa04d95783d7abad6df9cc.tar.bz2
gentoo-d687a5bea74cfcceb0aa04d95783d7abad6df9cc.zip
dev-python/fakeredis: New package (test dep of sentry-sdk)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fakeredis/Manifest1
-rw-r--r--dev-python/fakeredis/fakeredis-1.4.3.ebuild37
-rw-r--r--dev-python/fakeredis/metadata.xml7
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
new file mode 100644
index 000000000000..716be373f2bf
--- /dev/null
+++ b/dev-python/fakeredis/Manifest
@@ -0,0 +1 @@
+DIST fakeredis-1.4.3.gh.tar.gz 64936 BLAKE2B 61f85ec5c5b05b45f421a422f0cab072c24864a970097d2e15340ba7655ba9182c312091b9b6570aaf366fc241bb430fa528068db2728d42b615aecbec635d1a SHA512 56a0cc6d51025ceb24bb46dcdb2a8f638699f9928552d9b0f1592ff93903397304a9166e167de4d7c1d9f718a486f71e249c36e7c0667bde59f46710896da987
diff --git a/dev-python/fakeredis/fakeredis-1.4.3.ebuild b/dev-python/fakeredis/fakeredis-1.4.3.ebuild
new file mode 100644
index 000000000000..68b7378cac63
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-1.4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/jamesls/fakeredis/
+ https://pypi.org/project/fakeredis/"
+SRC_URI="
+ https://github.com/jamesls/fakeredis/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local excludes=(
+ # tests for use with aioredis, not packaged in ::gentoo
+ --ignore test/test_aioredis.py
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+
+ pytest -vv "${excludes[@]}" || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/fakeredis/metadata.xml b/dev-python/fakeredis/metadata.xml
new file mode 100644
index 000000000000..266e3f19ca59
--- /dev/null
+++ b/dev-python/fakeredis/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>