summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-17 00:41:22 +0100
committerSam James <sam@gentoo.org>2021-10-17 00:41:57 +0100
commitd6a0bf9437a7278215c25a7e3f65cdbb5a8608d6 (patch)
tree39c7fb2be34eec35236199c63ea6533801e10d3c
parentapp-misc/lcdproc: drop old version (diff)
downloadgentoo-d6a0bf9437a7278215c25a7e3f65cdbb5a8608d6.tar.gz
gentoo-d6a0bf9437a7278215c25a7e3f65cdbb5a8608d6.tar.bz2
gentoo-d6a0bf9437a7278215c25a7e3f65cdbb5a8608d6.zip
dev-util/clazy: run tests against built copy of clazy
This doesn't get us all of the way there yet though, tests still fail due to Clang shenanigans with include paths(?) Bug: https://bugs.gentoo.org/811723 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/clazy/clazy-1.10.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-util/clazy/clazy-1.10.ebuild b/dev-util/clazy/clazy-1.10.ebuild
index 7f7ef80b9200..160c50c5c641 100644
--- a/dev-util/clazy/clazy-1.10.ebuild
+++ b/dev-util/clazy/clazy-1.10.ebuild
@@ -36,3 +36,9 @@ src_configure() {
export LLVM_ROOT="/usr/lib/llvm/$(ver_cut 1 ${clang_version##sys-devel/clang-})"
cmake_src_configure
}
+
+src_test() {
+ # Run tests against built copy, not installed
+ # bug #811723
+ PATH="${BUILD_DIR}/bin:${PATH}" LD_LIBRARY_PATH="${BUILD_DIR}/lib" cmake_src_test
+}