summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-04-08 15:10:15 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-04-09 14:49:27 +0300
commitd6ce6fc0bb31b65716e1c69baa27367c7a7a08f7 (patch)
tree5742293754c3eadc54c1e6d33d2d819dc5580b96
parentdev-python/lunr: add py3.9 (diff)
downloadgentoo-d6ce6fc0bb31b65716e1c69baa27367c7a7a08f7.tar.gz
gentoo-d6ce6fc0bb31b65716e1c69baa27367c7a7a08f7.tar.bz2
gentoo-d6ce6fc0bb31b65716e1c69baa27367c7a7a08f7.zip
dev-python/abydos: add py3.9
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-python/abydos/abydos-0.5.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/abydos/abydos-0.5.0-r1.ebuild b/dev-python/abydos/abydos-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..7bb0fc5c9d44
--- /dev/null
+++ b/dev-python/abydos/abydos-0.5.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abydos NLP/IR library"
+HOMEPAGE="https://github.com/chrislit/abydos"
+SRC_URI="https://github.com/chrislit/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Requires access to the internet
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/deprecation[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? (
+ dev-python/nltk[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+# Extension error: You must configure the bibtex_bibfiles setting
+#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-bibtex
+
+python_prepare_all() {
+ # do not depend on pytest-cov
+ sed -i -e '/addopts/d' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}