summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-06-11 11:04:00 +0100
committerMarek Szuba <marecki@gentoo.org>2019-06-11 11:04:54 +0100
commitd6fe60098df1cf4171949d119b5b7a9aa3edd343 (patch)
tree78ca2d5459a200f8dbf1397bb5558318ff414713
parentmail-mta/exim: revbump for fix for bug #687554 (diff)
downloadgentoo-d6fe60098df1cf4171949d119b5b7a9aa3edd343.tar.gz
gentoo-d6fe60098df1cf4171949d119b5b7a9aa3edd343.tar.bz2
gentoo-d6fe60098df1cf4171949d119b5b7a9aa3edd343.zip
dev-util/intel-graphics-compiler: bump to 1.0.8
Now with proper gcc-9.1 support. Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
-rw-r--r--dev-util/intel-graphics-compiler/Manifest1
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-compiler/Manifest b/dev-util/intel-graphics-compiler/Manifest
index 7c277441e468..8519d5367a49 100644
--- a/dev-util/intel-graphics-compiler/Manifest
+++ b/dev-util/intel-graphics-compiler/Manifest
@@ -1,2 +1,3 @@
DIST intel-graphics-compiler-1.0.3.tar.gz 6721202 BLAKE2B 2934778e931a4b38a239ede5944757cc42c0a965e700ba471272ba8e9ca08b1c1c790c920ed6896a870985b1d2819a182a9aaf5a5a8cbfc13038ecd7cf1def1e SHA512 c0c0cc21263b71bc57aed43a3e8bd641ea7853db0a574823a70abb592a69b7f8a9f426e88e7fddea4cf6a14de44e064f80abcfa3ea709701e5003e0d4b7adfb0
DIST intel-graphics-compiler-1.0.4.tar.gz 6720515 BLAKE2B 2f9ac9a2435bac785b6a9f3cb8c63eb570ee1a87eca9682fa1c09363f5da3b258e22ad1c5b1628a1537b36afb7c6f6e66f2052b31ef7fdff0bc43cf67fad55ba SHA512 0b748b33c4c1822d8fb159dbbbeb35f0573d3eb464e3be0a94771069e47a019d6cbe878d2d2a1969ec87b051d62ff2f77db88b02238e9a74d8f62fc71f07e264
+DIST intel-graphics-compiler-1.0.8.tar.gz 6428984 BLAKE2B 1835f86da24162af0f568794fd084c12cf8950601a74d3aaef928739d7ef942a23b2309713976b2fd67684d7360706155610ee7a80db0dbc217ff5b502b254d2 SHA512 43c54858fcc5ec5941d79ed34774077bcd5ece80d6d2bb28526b15ffe5237dddbcef2c13e4cc21faf35851174ed5a5b1af65db9bdd3281657e1e09456b761c18
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8.ebuild
new file mode 100644
index 000000000000..e792758ac3dd
--- /dev/null
+++ b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib llvm
+
+DESCRIPTION="LLVM-based OpenCL compiler targetting Intel Gen graphics hardware"
+HOMEPAGE="https://github.com/intel/intel-graphics-compiler"
+SRC_URI="https://github.com/intel/${PN}/archive/igc-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON="sys-devel/llvm:8=[${MULTILIB_USEDEP}]
+ dev-libs/opencl-clang:8=[${MULTILIB_USEDEP}]"
+DEPEND="${COMMON}"
+RDEPEND="${COMMON}"
+
+LLVM_MAX_SLOT=8
+
+S="${WORKDIR}"/${PN}-igc-${PV}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_LIBRARY_PATH=$(get_llvm_prefix)/$(get_libdir)
+ -DIGC_OPTION__FORCE_SYSTEM_LLVM=ON
+ -DIGC_PREFERRED_LLVM_VERSION=8
+ # Until a new official release of opencl-clang
+ -DCOMMON_CLANG_LIBRARY_NAME=common_clang
+ )
+ cmake-utils_src_configure
+}