summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-12-31 00:26:20 +0100
committerLouis Sautier <sbraz@gentoo.org>2021-12-31 00:30:48 +0100
commitd72ce19f1c1751f430d5fe99db3d7d44a9da23ca (patch)
treeeb6177d377ebbfb1de37af795411f6b5c5f4e36e
parentapp-admin/supervisor: add 4.2.4 (diff)
downloadgentoo-d72ce19f1c1751f430d5fe99db3d7d44a9da23ca.tar.gz
gentoo-d72ce19f1c1751f430d5fe99db3d7d44a9da23ca.tar.bz2
gentoo-d72ce19f1c1751f430d5fe99db3d7d44a9da23ca.zip
app-admin/supervisor: drop 4.2.0, 4.2.1
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--app-admin/supervisor/Manifest2
-rw-r--r--app-admin/supervisor/supervisor-4.2.0.ebuild62
-rw-r--r--app-admin/supervisor/supervisor-4.2.1.ebuild54
3 files changed, 0 insertions, 118 deletions
diff --git a/app-admin/supervisor/Manifest b/app-admin/supervisor/Manifest
index c461f2f8bbd0..f20cd79a3b38 100644
--- a/app-admin/supervisor/Manifest
+++ b/app-admin/supervisor/Manifest
@@ -1,4 +1,2 @@
-DIST supervisor-4.2.0.tar.gz 456056 BLAKE2B 51b66cfc34505b937c47c9b510d81bcc777b9372fdeb2e08fc25153d2718cd2682258b812630160954587ceb992e1a528cdd5bf0d270139f7ffac9463ac2f015 SHA512 626d806f4b03be7cbff795afd1bdb3ff5ca5ecf44f035909ea1aa9360da9fa3047b2fe05543190bf1442f01dcdd403be19fcd907519bf7e26615900bc4bf9d0f
-DIST supervisor-4.2.1.tar.gz 460935 BLAKE2B 0c65f904599c1e8a04cd3a71085e2b2a5460691c2bfd790d3b7c10449cae08472bcd72a870cbe611801434624f405ea3e245f156cab93f25a8df784b58d948d7 SHA512 c560ef959f8d580fb20c1812aa2a838c9feaeb3726a754e8084fa8c7406ff9258139b55b081558b8d8f33e4672cdfad40695170f55412a5e85a6c1aed0f11657
DIST supervisor-4.2.2.tar.gz 463657 BLAKE2B 766feffcbd70b575b6b7dfd6ed98e3510e0fd9362c423b677d44a2b5dd23ded14a349a279d3d28d4fd9e04a2175c8f00e24c07df310b61d34c7f69f60d26a4ac SHA512 f787206e6c6a5d3dfc4284974a4a87cbcaeac0c705afb2b8eae53f066413bd9e68095c5309e29625e01469a4748613370e1ac0d7be84b9d72c3623244bdd2eb3
DIST supervisor-4.2.4.tar.gz 465151 BLAKE2B 91b99a64950dc874bdc008ba53ca8b1962cc34981fee27c2fd82956d73ace9eaaf91439ef6be40530c4860fe1eee193e19b51ab81050f7368aa7d31f8444c785 SHA512 38c55aeadb8664337b667aad891a3a2134ae4af88e90d636054e6be9aebc8a3ef87d79d15fcafd2b9966af562deeedc96ac3730bde9439dde30208f0a874f2d7
diff --git a/app-admin/supervisor/supervisor-4.2.0.ebuild b/app-admin/supervisor/supervisor-4.2.0.ebuild
deleted file mode 100644
index 44d710173315..000000000000
--- a/app-admin/supervisor/supervisor-4.2.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7,8} )
-# xml.etree.ElementTree module required.
-PYTHON_REQ_USE="xml(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1 systemd
-
-MY_PV="${PV/_beta/b}"
-
-DESCRIPTION="A system for controlling process state under UNIX"
-HOMEPAGE="http://supervisord.org/ https://pypi.org/project/supervisor/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="repoze ZPL BSD HPND GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="acct-group/supervisor"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Skip one test that currently fails
- # https://github.com/Supervisor/supervisor/issues/1346
- sed -i 's/test_prepare_socket/_&/' \
- supervisor/tests/test_socket_manager.py || die
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- newinitd "${FILESDIR}/init.d-r2" supervisord
- newconfd "${FILESDIR}/conf.d-r1" supervisord
- dodoc supervisor/skel/sample.conf
- keepdir /etc/supervisord.d
- insinto /etc
- doins "${FILESDIR}/supervisord.conf"
- keepdir /var/log/supervisor
- systemd_dounit "${FILESDIR}/supervisord.service"
-}
-
-pkg_preinst() {
- fowners :supervisor /var/log/supervisor
- fperms 750 /var/log/supervisor
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- # This is a new installation
- elog "You may install your configuration files in ${EROOT}/etc/supervisord.d"
- elog "For config examples, see ${EROOT}/usr/share/doc/${PF}/sample.conf.bz2"
- elog ""
- elog "By default, only members of the supervisor group can run supervisorctl."
- fi
-}
diff --git a/app-admin/supervisor/supervisor-4.2.1.ebuild b/app-admin/supervisor/supervisor-4.2.1.ebuild
deleted file mode 100644
index 999e761f2fc8..000000000000
--- a/app-admin/supervisor/supervisor-4.2.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
-# xml.etree.ElementTree module required.
-PYTHON_REQ_USE="xml(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1 systemd
-
-MY_PV="${PV/_beta/b}"
-
-DESCRIPTION="A system for controlling process state under UNIX"
-HOMEPAGE="http://supervisord.org/ https://pypi.org/project/supervisor/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="repoze ZPL BSD HPND GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="acct-group/supervisor"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
- newinitd "${FILESDIR}/init.d-r2" supervisord
- newconfd "${FILESDIR}/conf.d-r1" supervisord
- dodoc supervisor/skel/sample.conf
- keepdir /etc/supervisord.d
- insinto /etc
- doins "${FILESDIR}/supervisord.conf"
- keepdir /var/log/supervisor
- systemd_dounit "${FILESDIR}/supervisord.service"
-}
-
-pkg_preinst() {
- fowners :supervisor /var/log/supervisor
- fperms 750 /var/log/supervisor
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- # This is a new installation
- elog "You may install your configuration files in ${EROOT}/etc/supervisord.d"
- elog "For config examples, see ${EROOT}/usr/share/doc/${PF}/sample.conf.bz2"
- elog ""
- elog "By default, only members of the supervisor group can run supervisorctl."
- fi
-}