summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2016-12-23 13:30:12 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2016-12-23 13:30:12 -0500
commitd73f7a55043e122d7af23457e7061de42b1fc4fe (patch)
tree94e30d7be7fe2e4ca6c996be94a1578b1ca15a0c
parenttmpfiles.eclass: fix call to tmpfiles for #603342 (diff)
downloadgentoo-d73f7a55043e122d7af23457e7061de42b1fc4fe.tar.gz
gentoo-d73f7a55043e122d7af23457e7061de42b1fc4fe.tar.bz2
gentoo-d73f7a55043e122d7af23457e7061de42b1fc4fe.zip
mail-client/roundcube: Removing Insecure Versions
Bug: 601410 Package-Manager: portage-2.3.0
-rw-r--r--mail-client/roundcube/Manifest3
-rw-r--r--mail-client/roundcube/roundcube-1.2.0.ebuild75
-rw-r--r--mail-client/roundcube/roundcube-1.2.1.ebuild75
-rw-r--r--mail-client/roundcube/roundcube-1.2.2.ebuild75
4 files changed, 0 insertions, 228 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 385f193cccdf..53b8b17ac637 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -1,4 +1 @@
-DIST roundcubemail-1.2.0.tar.gz 3453543 SHA256 e3b89c2772c2c5990da9bca640bc342f486edf356016cf717e6a1083c822b523 SHA512 3d97e816560830437902ede352e8be81cd93050975934b9dfc86ccf745234119bdf63d5f882fa0d1cc445575c1ea05906a87ae81befdb0bbb38002433e4de199 WHIRLPOOL f9b14ffb2520cd7eda798eb96ec8547af9f5b8d288605d5d777d126cddb3f531f53887ae9bd9b16be7bf194e87165ff48722885328c6dab0d1c1a0ee589817c4
-DIST roundcubemail-1.2.1.tar.gz 3559023 SHA256 05c0b17c8951db1d220f2f2186e6981545789da0d084a543e28a7d2511db8302 SHA512 7044e4308fff85a23826e4f4652df7e825d713b977696c0d29d563f419cc4e060ef202f824463823c3f348c7e9f4ce8c58d073c960b371c0b9ca3bd77c5453ca WHIRLPOOL 79a47d9bd65578c0177ffa9438d8a9b305e2d725536209955b04fbfc42a31ef3060d351b638dba72ede3fd8b1ef42a9af34493f80ff393a91b8ab31634bf318a
-DIST roundcubemail-1.2.2.tar.gz 3562148 SHA256 6c647ed28ea0ae1b730a1784018b63884e65ed6036208e9c3a6ee62123fe856d SHA512 f5482ad424ecdfa275015c51162c465eadb3888f929a86fcd4ca52a6f880ea48c748cc3ecbbe9dd4f5a4fdc823599a93e965855e362958ff46e829e145c7d04b WHIRLPOOL 74c760bcd8f6dc9b1d60ffea84ad66c74a66ef7a5c3164b51ae329ab3d502731799a6dedd069ea3a76a26492213829fd58d43c4f7e38cd843d4ecb35c04c7cfd
DIST roundcubemail-1.2.3.tar.gz 3599096 SHA256 2df820d2ccc7bb320f854a821a1dc9983792f42a3353a1d38fe0822d94980d4d SHA512 af64b5ccb95b30ee483c573098741098427dd9755526253490f657a10fed3764f5ed8f336d0a8cb82bcce65d8840b0892d6e4746ce93bc595cfd29f66ea45795 WHIRLPOOL 08551297ca37d8f26ab9fa13c60db7f5b477251a639519285003cedc6971dbf2b6f6c43d1adc6334bfc67adfb85271b8bfe52d50a7416ba31d3ea38284ac28b7
diff --git a/mail-client/roundcube/roundcube-1.2.0.ebuild b/mail-client/roundcube/roundcube-1.2.0.ebuild
deleted file mode 100644
index c261db258fdb..000000000000
--- a/mail-client/roundcube/roundcube-1.2.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit webapp
-
-MY_PN=${PN}mail
-MY_P=${MY_PN}-${PV/_/-}
-
-DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
-HOMEPAGE="http://roundcube.net"
-SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${PV/_/-}/${MY_P}.tar.gz"
-
-# roundcube is GPL-licensed, the rest of the licenses here are
-# for bundled PEAR components, googiespell and utf8.class.php
-LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
-KEYWORDS="amd64 arm ~hppa ppc ~ppc64 ~sparc x86"
-
-IUSE="enigma ldap managesieve mysql postgres sqlite ssl spell"
-REQUIRED_USE="|| ( mysql postgres sqlite )"
-
-# this function only sets DEPEND so we need to include that in RDEPEND
-need_httpd_cgi
-
-RDEPEND="
- ${DEPEND}
- >=dev-lang/php-5.3.7[crypt,filter,gd,iconv,json,ldap?,pdo,postgres?,session,sockets,sqlite?,ssl?,unicode,xml]
- >=dev-php/PEAR-Auth_SASL-1.0.6
- >=dev-php/PEAR-Mail_Mime-1.8.9
- >=dev-php/PEAR-Mail_mimeDecode-1.5.5
- >=dev-php/PEAR-Net_IDNA2-0.1.1
- >=dev-php/PEAR-Net_SMTP-1.6.2
- virtual/httpd-php
- enigma? ( >=dev-php/PEAR-Crypt_GPG-1.2.0 app-crypt/gnupg )
- ldap? ( >=dev-php/PEAR-Net_LDAP2-2.0.12 dev-php/PEAR-Net_LDAP3 )
- managesieve? ( >=dev-php/PEAR-Net_Sieve-1.3.2 )
- mysql? ( || ( dev-lang/php[mysql] dev-lang/php[mysqli] ) )
- spell? ( dev-lang/php[curl,spell] )
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_install() {
- webapp_src_preinst
- dodoc CHANGELOG INSTALL README.md UPGRADING
-
- insinto "${MY_HTDOCSDIR}"
- doins -r [[:lower:]]* SQL
- doins .htaccess
-
- webapp_serverowned "${MY_HTDOCSDIR}"/logs
- webapp_serverowned "${MY_HTDOCSDIR}"/temp
-
- webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
- webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE.txt"
- webapp_src_install
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
-
- ewarn
- ewarn "When upgrading from <= 0.9, note that the old configuration files"
- ewarn "named main.inc.php and db.inc.php are deprecated and should be"
- ewarn "replaced with one single config.inc.php file."
- ewarn
- ewarn "Run the ./bin/update.sh script to convert those"
- ewarn "or manually merge the files."
- ewarn
- ewarn "The new config.inc.php should only contain options that"
- ewarn "differ from the ones listed in defaults.inc.php."
- ewarn
-}
diff --git a/mail-client/roundcube/roundcube-1.2.1.ebuild b/mail-client/roundcube/roundcube-1.2.1.ebuild
deleted file mode 100644
index 2976d26befc5..000000000000
--- a/mail-client/roundcube/roundcube-1.2.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit webapp
-
-MY_PN=${PN}mail
-MY_P=${MY_PN}-${PV/_/-}
-
-DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
-HOMEPAGE="http://roundcube.net"
-SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${PV/_/-}/${MY_P}.tar.gz"
-
-# roundcube is GPL-licensed, the rest of the licenses here are
-# for bundled PEAR components, googiespell and utf8.class.php
-LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
-KEYWORDS="~amd64 ~arm ~x86"
-
-IUSE="enigma ldap managesieve mysql postgres sqlite ssl spell"
-REQUIRED_USE="|| ( mysql postgres sqlite )"
-
-# this function only sets DEPEND so we need to include that in RDEPEND
-need_httpd_cgi
-
-RDEPEND="
- ${DEPEND}
- >=dev-lang/php-5.3.7[crypt,filter,gd,iconv,json,ldap?,pdo,postgres?,session,sockets,sqlite?,ssl?,unicode,xml]
- >=dev-php/PEAR-Auth_SASL-1.0.6
- >=dev-php/PEAR-Mail_Mime-1.8.9
- >=dev-php/PEAR-Mail_mimeDecode-1.5.5
- >=dev-php/PEAR-Net_IDNA2-0.1.1
- >=dev-php/PEAR-Net_SMTP-1.6.2
- virtual/httpd-php
- enigma? ( >=dev-php/PEAR-Crypt_GPG-1.4.0 app-crypt/gnupg )
- ldap? ( >=dev-php/PEAR-Net_LDAP2-2.0.12 dev-php/PEAR-Net_LDAP3 )
- managesieve? ( >=dev-php/PEAR-Net_Sieve-1.3.2 )
- mysql? ( || ( dev-lang/php[mysql] dev-lang/php[mysqli] ) )
- spell? ( dev-lang/php[curl,spell] )
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_install() {
- webapp_src_preinst
- dodoc CHANGELOG INSTALL README.md UPGRADING
-
- insinto "${MY_HTDOCSDIR}"
- doins -r [[:lower:]]* SQL
- doins .htaccess
-
- webapp_serverowned "${MY_HTDOCSDIR}"/logs
- webapp_serverowned "${MY_HTDOCSDIR}"/temp
-
- webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
- webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE.txt"
- webapp_src_install
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
-
- ewarn
- ewarn "When upgrading from <= 0.9, note that the old configuration files"
- ewarn "named main.inc.php and db.inc.php are deprecated and should be"
- ewarn "replaced with one single config.inc.php file."
- ewarn
- ewarn "Run the ./bin/update.sh script to convert those"
- ewarn "or manually merge the files."
- ewarn
- ewarn "The new config.inc.php should only contain options that"
- ewarn "differ from the ones listed in defaults.inc.php."
- ewarn
-}
diff --git a/mail-client/roundcube/roundcube-1.2.2.ebuild b/mail-client/roundcube/roundcube-1.2.2.ebuild
deleted file mode 100644
index 2976d26befc5..000000000000
--- a/mail-client/roundcube/roundcube-1.2.2.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit webapp
-
-MY_PN=${PN}mail
-MY_P=${MY_PN}-${PV/_/-}
-
-DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
-HOMEPAGE="http://roundcube.net"
-SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${PV/_/-}/${MY_P}.tar.gz"
-
-# roundcube is GPL-licensed, the rest of the licenses here are
-# for bundled PEAR components, googiespell and utf8.class.php
-LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
-KEYWORDS="~amd64 ~arm ~x86"
-
-IUSE="enigma ldap managesieve mysql postgres sqlite ssl spell"
-REQUIRED_USE="|| ( mysql postgres sqlite )"
-
-# this function only sets DEPEND so we need to include that in RDEPEND
-need_httpd_cgi
-
-RDEPEND="
- ${DEPEND}
- >=dev-lang/php-5.3.7[crypt,filter,gd,iconv,json,ldap?,pdo,postgres?,session,sockets,sqlite?,ssl?,unicode,xml]
- >=dev-php/PEAR-Auth_SASL-1.0.6
- >=dev-php/PEAR-Mail_Mime-1.8.9
- >=dev-php/PEAR-Mail_mimeDecode-1.5.5
- >=dev-php/PEAR-Net_IDNA2-0.1.1
- >=dev-php/PEAR-Net_SMTP-1.6.2
- virtual/httpd-php
- enigma? ( >=dev-php/PEAR-Crypt_GPG-1.4.0 app-crypt/gnupg )
- ldap? ( >=dev-php/PEAR-Net_LDAP2-2.0.12 dev-php/PEAR-Net_LDAP3 )
- managesieve? ( >=dev-php/PEAR-Net_Sieve-1.3.2 )
- mysql? ( || ( dev-lang/php[mysql] dev-lang/php[mysqli] ) )
- spell? ( dev-lang/php[curl,spell] )
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_install() {
- webapp_src_preinst
- dodoc CHANGELOG INSTALL README.md UPGRADING
-
- insinto "${MY_HTDOCSDIR}"
- doins -r [[:lower:]]* SQL
- doins .htaccess
-
- webapp_serverowned "${MY_HTDOCSDIR}"/logs
- webapp_serverowned "${MY_HTDOCSDIR}"/temp
-
- webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
- webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE.txt"
- webapp_src_install
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
-
- ewarn
- ewarn "When upgrading from <= 0.9, note that the old configuration files"
- ewarn "named main.inc.php and db.inc.php are deprecated and should be"
- ewarn "replaced with one single config.inc.php file."
- ewarn
- ewarn "Run the ./bin/update.sh script to convert those"
- ewarn "or manually merge the files."
- ewarn
- ewarn "The new config.inc.php should only contain options that"
- ewarn "differ from the ones listed in defaults.inc.php."
- ewarn
-}