summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-17 19:31:08 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-17 19:31:08 +0200
commitd79631c7b6565742790a9be723db35d7a81a0b36 (patch)
tree386872b18dcb16a9f5e7545e5bd35522eaec208b
parentdev-python/jupyter: Add python 3.8/3.9 (diff)
downloadgentoo-d79631c7b6565742790a9be723db35d7a81a0b36.tar.gz
gentoo-d79631c7b6565742790a9be723db35d7a81a0b36.tar.bz2
gentoo-d79631c7b6565742790a9be723db35d7a81a0b36.zip
dev-python/vpython: Add python 3.8
Bug: https://bugs.gentoo.org/718882 Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-python/vpython/vpython-7.6.1-r1.ebuild (renamed from dev-python/vpython/vpython-7.6.1.ebuild)21
1 files changed, 14 insertions, 7 deletions
diff --git a/dev-python/vpython/vpython-7.6.1.ebuild b/dev-python/vpython/vpython-7.6.1-r1.ebuild
index d2f5ea8d2a95..1d0df6203ec8 100644
--- a/dev-python/vpython/vpython-7.6.1.ebuild
+++ b/dev-python/vpython/vpython-7.6.1-r1.ebuild
@@ -1,20 +1,27 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_7 )
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+
inherit distutils-r1
DESCRIPTION="VPython for Jupyter notebook"
HOMEPAGE="http://www.vpython.org/ https://pypi.org/project/vpython/"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-DEPEND="dev-python/cython[${PYTHON_USEDEP}]
- dev-python/versioneer[${PYTHON_USEDEP}]
+
+RDEPEND="
+ dev-python/autobahn[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
dev-python/jupyter[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/autobahn[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
+ dev-python/versioneer[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+DEPEND="
+ ${RDEPEND}
+ ${BDEPEND}"
+
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"