summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2019-03-14 17:16:46 +0100
committerAndrey Grozin <grozin@gentoo.org>2019-03-14 17:17:35 +0100
commitd7b090b997c59b12f2762be59902c51821af1ae9 (patch)
treed4dc41a203d4d3d035d6172c1587b38f26f5f8d7
parentsci-geosciences/geocode-glib: bump to 3.26.1, nominatim search crash fix (diff)
downloadgentoo-d7b090b997c59b12f2762be59902c51821af1ae9.tar.gz
gentoo-d7b090b997c59b12f2762be59902c51821af1ae9.tar.bz2
gentoo-d7b090b997c59b12f2762be59902c51821af1ae9.zip
net-misc/dropbox-cli: bump to 19
Closes: https://bugs.gentoo.org/show_bug.cgi?id=678958 Closes: https://bugs.gentoo.org/show_bug.cgi?id=647222 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--net-misc/dropbox-cli/Manifest1
-rw-r--r--net-misc/dropbox-cli/dropbox-cli-19.ebuild31
-rw-r--r--net-misc/dropbox-cli/files/dropbox-cli-19-completion2
3 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/dropbox-cli/Manifest b/net-misc/dropbox-cli/Manifest
index 505b89f736f6..531eb6aa2009 100644
--- a/net-misc/dropbox-cli/Manifest
+++ b/net-misc/dropbox-cli/Manifest
@@ -1,2 +1,3 @@
DIST dropbox-cli-1.6.0.py.xz 17632 BLAKE2B 244e36ea2b1f3a7ad36884de227933f91ca94dd907fadc300cc599336b4a09efec54e9f4cd26aa922609755812cfcd0f506866d0a66e74700c1b90a8c4347683 SHA512 06fcbba67031c18fe1840f592d04039a7c78848d6e77ae8cca04881f5f72ada7fb368921e2ae3b92d161e49bf91eae0f41b559a210eacd0dc203c51134597857
DIST dropbox-cli-1.py.xz 17580 BLAKE2B 9bb165f419df716acfb485f40e3b40238d06db1448cf12731499f8b891d1a2b3de57ae405807c9b61316bea65eca133c95a88a475db210173efb915707e2154d SHA512 d5510a66a5605e474059bb761cc2f33cd4d23481e85f040b049c36759a030f1e7072a9ad2cc7f72e59507767aa375ff3ea1c06d7bf702eb7ba7d698db2bfefe5
+DIST dropbox-cli-19.py.xz 13960 BLAKE2B 16d33155cbe5449434ff9fc5a9fddca9a7cd20bd3ff8fc46f4badcc30d71f6b0b6adde6f6d0ad73702e4dd2957cc00f88f49b2580c289525784f97d4502e008d SHA512 b5ea1632c135232f4705a0e95419d176638e6a830a2a7d32f955c615328097b987887513cf06103b452a7efe2690ffe351a275267451db9d2998d19ac6f8f85f
diff --git a/net-misc/dropbox-cli/dropbox-cli-19.ebuild b/net-misc/dropbox-cli/dropbox-cli-19.ebuild
new file mode 100644
index 000000000000..a8ca71ef1800
--- /dev/null
+++ b/net-misc/dropbox-cli/dropbox-cli-19.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit python-r1 bash-completion-r1
+
+DESCRIPTION="Cli interface for dropbox (python), part of nautilus-dropbox"
+HOMEPAGE="https://www.dropbox.com/"
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.py.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="net-misc/dropbox
+ ${PYTHON_DEPS}
+ dev-python/pygpgme[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin ${P}.py ${PN}
+ python_replicate_script "${D}"/usr/bin/${PN}
+ newbashcomp "${FILESDIR}"/${P}-completion ${PN}
+}
diff --git a/net-misc/dropbox-cli/files/dropbox-cli-19-completion b/net-misc/dropbox-cli/files/dropbox-cli-19-completion
new file mode 100644
index 000000000000..dbf5803842d4
--- /dev/null
+++ b/net-misc/dropbox-cli/files/dropbox-cli-19-completion
@@ -0,0 +1,2 @@
+# dropbox-cli completion
+complete -W 'autostart exclude filestatus help lansync ls proxy puburl running sharelink start status stop throttle update' dropbox-cli