summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-10-16 17:23:48 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-10-16 18:23:15 +0200
commitd7f7628019d2ee6e30d698740d7e7ed0e11722c8 (patch)
tree4e2d8cfa3eac5c21066b21a7d2eef11038caf6d5
parentdev-qt/qtx11extras: amd64 stable wrt bug #664566 (diff)
downloadgentoo-d7f7628019d2ee6e30d698740d7e7ed0e11722c8.tar.gz
gentoo-d7f7628019d2ee6e30d698740d7e7ed0e11722c8.tar.bz2
gentoo-d7f7628019d2ee6e30d698740d7e7ed0e11722c8.zip
dev-db/percona-server: small changes
- Build system will always check for dev-libs/protobuf when USE=server - Make sure to subscribe to protobuf's subslot when USE=rocksdb - Don't install files in /usr/share/doc/${P}/scripts -- they are already installed in /usr/share/mysql Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-db/percona-server/percona-server-5.7.23.23-r1.ebuild (renamed from dev-db/percona-server/percona-server-5.7.23.23.ebuild)45
1 files changed, 17 insertions, 28 deletions
diff --git a/dev-db/percona-server/percona-server-5.7.23.23.ebuild b/dev-db/percona-server/percona-server-5.7.23.23-r1.ebuild
index d87397f9aea5..bc88d79f260d 100644
--- a/dev-db/percona-server/percona-server-5.7.23.23.ebuild
+++ b/dev-db/percona-server/percona-server-5.7.23.23-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-MY_EXTRAS_VER="20181014-2320Z"
+MY_EXTRAS_VER="20181016-1606Z"
CMAKE_MAKEFILE_GENERATOR=emake
@@ -92,14 +92,17 @@ COMMON_DEPEND="net-misc/curl:=
server? (
>=app-arch/lz4-0_p131:=
cjk? ( app-text/mecab:= )
- numa? ( sys-process/numactl )
- pam? ( virtual/pam:0= )
experimental? (
dev-libs/libevent:=
dev-libs/protobuf:=
net-libs/libtirpc:=
)
- rocksdb? ( app-arch/zstd:= )
+ numa? ( sys-process/numactl )
+ pam? ( virtual/pam:0= )
+ rocksdb? (
+ app-arch/zstd:=
+ dev-libs/protobuf:=
+ )
tokudb? (
app-arch/snappy:=
app-arch/xz-utils:=
@@ -121,8 +124,10 @@ COMMON_DEPEND="net-misc/curl:=
"
DEPEND="${COMMON_DEPEND}
|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )
+ dev-libs/protobuf
virtual/yacc
server? (
+ dev-libs/libevent
experimental? ( net-libs/rpcsvc-proto )
)
static? ( sys-libs/ncurses[static-libs] )
@@ -279,9 +284,9 @@ pkg_postinst() {
# Note about configuration change
einfo
elog "This version of ${PN} reorganizes the configuration from a single my.cnf"
- elog "to several files in /etc/mysql/${PN}.d."
+ elog "to several files in /etc/mysql/mysql.d."
elog "Please backup any changes you made to /etc/mysql/my.cnf"
- elog "and add them as a new file under /etc/mysql/${PN}.d with a .cnf extension."
+ elog "and add them as a new file under /etc/mysql/mysql.d with a .cnf extension."
elog "You may have as many files as needed and they are read alphabetically."
elog "Be sure the options have the appropriate section headers, i.e. [mysqld]."
einfo
@@ -323,11 +328,11 @@ src_prepare() {
# Remove bundled libs so we cannot accidentally use them
# We keep extra/lz4 directory because we use extra/lz4/xxhash.c via sql/CMakeLists.txt:394
rm -rv \
- "${S}"/libevent \
- "${S}"/zlib \
"${S}"/extra/protobuf \
+ "${S}"/libevent \
"${S}"/storage/rocksdb/third_party \
"${S}"/storage/tokudb/PerconaFT/third_party \
+ "${S}"/zlib \
|| die
# Remove the centos and rhel selinux policies to support mysqld_safe under SELinux
@@ -773,31 +778,21 @@ multilib_src_install_all() {
sed -e "s!@DATADIR@!${MY_DATADIR}!g" \
"${FILESDIR}/${mycnf_src}" \
> "${TMPDIR}/my.cnf.ok" || die
+
if use prefix ; then
sed -i -r -e '/^user[[:space:]]*=[[:space:]]*mysql$/d' \
"${TMPDIR}/my.cnf.ok" || die
fi
+
if use latin1 ; then
sed -i \
-e "/character-set/s|utf8|latin1|g" \
"${TMPDIR}/my.cnf.ok" || die
fi
- eprefixify "${TMPDIR}/my.cnf.ok"
- newins "${TMPDIR}/my.cnf.ok" 50-distro-server.cnf
- einfo "Including support files and sample configurations"
- docinto "support-files"
- local script
- for script in \
- "${S}"/support-files/magic
- do
- [[ -f "$script" ]] && dodoc "${script}"
- done
+ eprefixify "${TMPDIR}/my.cnf.ok"
- docinto "scripts"
- for script in "${S}"/scripts/mysql* ; do
- [[ ( -f "$script" ) && ( "${script%.sh}" == "${script}" ) ]] && dodoc "${script}"
- done
+ newins "${TMPDIR}/my.cnf.ok" 50-distro-server.cnf
if use tokudb ; then
# Remove some unwanted files
@@ -810,12 +805,6 @@ multilib_src_install_all() {
fi
fi
- if ! use client-libs ; then
- rm -rv \
- "${ED%/}"/usr/$(get_libdir)/pkgconfig \
- || die
- fi
-
#Remove mytop if perl is not selected
[[ -e "${ED}/usr/bin/mytop" ]] && ! use perl && rm -f "${ED}/usr/bin/mytop"
}