summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-06-14 10:15:24 +0100
committerMarek Szuba <marecki@gentoo.org>2021-06-14 13:38:43 +0100
commitd82f7365821923e3b862343fb6b26489694f8b45 (patch)
tree607cc2fb14796c55c40a03434fd8404283943c3a
parentdev-python/subprocess-tee: remove obsolete TODO note (diff)
downloadgentoo-d82f7365821923e3b862343fb6b26489694f8b45.tar.gz
gentoo-d82f7365821923e3b862343fb6b26489694f8b45.tar.bz2
gentoo-d82f7365821923e3b862343fb6b26489694f8b45.zip
dev-python/sphinx_ansible_theme: initial import
Seems like it should work with CPython 3.10 but since upstream has not officially declared that version as supported yet, the package has got no test suite and the only revdep I know of (Ansible Molecule) depends on several packages which do not support 3.10 yet, let's play it safe. Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-python/sphinx_ansible_theme/Manifest1
-rw-r--r--dev-python/sphinx_ansible_theme/metadata.xml13
-rw-r--r--dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.6.0.ebuild20
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/sphinx_ansible_theme/Manifest b/dev-python/sphinx_ansible_theme/Manifest
new file mode 100644
index 000000000000..8dea597c4b16
--- /dev/null
+++ b/dev-python/sphinx_ansible_theme/Manifest
@@ -0,0 +1 @@
+DIST sphinx_ansible_theme-0.6.0.tar.gz 37606 BLAKE2B 3b27d15133e167602ce9515fb630ed9ecb0b0d346450417900e616476fa80aa216c033741121f82289d9e5bf977e01395663e5f61c4682576e8b773c17af2723 SHA512 d134a9e6eab0cab8e60c251a69e7b3dfa2864e5e19d65ce2e8b565a601e4b5255536f6b69ac17952ebd14929471a487200fc97c9c5e1f3f8232daf8e4ed63cef
diff --git a/dev-python/sphinx_ansible_theme/metadata.xml b/dev-python/sphinx_ansible_theme/metadata.xml
new file mode 100644
index 000000000000..0fb924872568
--- /dev/null
+++ b/dev-python/sphinx_ansible_theme/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">ansible-community/sphinx_ansible_theme</remote-id>
+ <remote-id type="pypi">sphinx-ansible-theme</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.6.0.ebuild b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.6.0.ebuild
new file mode 100644
index 000000000000..8b7f8535d306
--- /dev/null
+++ b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.6.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A reusable Ansible Sphinx theme"
+HOMEPAGE="https://github.com/ansible-community/sphinx_ansible_theme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]"