summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-07-31 11:01:18 +0200
committerPacho Ramos <pacho@gentoo.org>2024-07-31 11:23:09 +0200
commitd87d6ef4bd3de2ac5a7bc094c17b4285a9560771 (patch)
treec65a2d41aee32387ea703a65b36a631c7727bf52
parentsys-fs/android-file-transfer-linux: enable py3.12 (diff)
downloadgentoo-d87d6ef4bd3de2ac5a7bc094c17b4285a9560771.tar.gz
gentoo-d87d6ef4bd3de2ac5a7bc094c17b4285a9560771.tar.bz2
gentoo-d87d6ef4bd3de2ac5a7bc094c17b4285a9560771.zip
sys-fs/android-file-transfer-linux: sync live ebuild
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--sys-fs/android-file-transfer-linux/android-file-transfer-linux-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sys-fs/android-file-transfer-linux/android-file-transfer-linux-9999.ebuild b/sys-fs/android-file-transfer-linux/android-file-transfer-linux-9999.ebuild
index 6e72c38e8220..ae4c96bbe345 100644
--- a/sys-fs/android-file-transfer-linux/android-file-transfer-linux-9999.ebuild
+++ b/sys-fs/android-file-transfer-linux/android-file-transfer-linux-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake python-single-r1 xdg
@@ -15,7 +15,7 @@ if [[ "${PV}" = *9999 ]] ; then
EGIT_REPO_URI="https://github.com/whoozle/android-file-transfer-linux.git"
else
SRC_URI="https://github.com/whoozle/android-file-transfer-linux/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="amd64 ~x86"
fi
LICENSE="LGPL-2.1"
@@ -54,6 +54,10 @@ BDEPEND="
qt5? ( dev-qt/linguist-tools:5 )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.2-gcc13.patch
+)
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}