summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-15 09:56:34 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-15 10:04:58 +0100
commitd94948a58ad4574d9f016e5e16fd99b937af7b6e (patch)
tree3a21d1e774faef4e2054652884f6c89a581ca137
parentdev-python/proto-plus: Bump to 1.20.1 (diff)
downloadgentoo-d94948a58ad4574d9f016e5e16fd99b937af7b6e.tar.gz
gentoo-d94948a58ad4574d9f016e5e16fd99b937af7b6e.tar.bz2
gentoo-d94948a58ad4574d9f016e5e16fd99b937af7b6e.zip
dev-python/nbclient: Bump to 0.5.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nbclient/Manifest1
-rw-r--r--dev-python/nbclient/nbclient-0.5.11.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/nbclient/Manifest b/dev-python/nbclient/Manifest
index dfac5e5cfb91..3adc08ec7be3 100644
--- a/dev-python/nbclient/Manifest
+++ b/dev-python/nbclient/Manifest
@@ -1 +1,2 @@
+DIST nbclient-0.5.11.gh.tar.gz 75556 BLAKE2B 5c9e44ea1efc05457427ba6fb9bbb319efd5eb314ca4964e0df4b842faa3341f4f51ef74565434ddaf0dcf56c9e2a83ce7bd36ab6c50cc1d0349ecc50af75b51 SHA512 e4142dd28e21be7803651b8b7ed646e168a302edc2ec806b58fdd79454059fea3fedf270e1aaec6152433a15c2280bd38e4dfb0d740091a2ab2987530dbe3c6a
DIST nbclient-0.5.5.gh.tar.gz 72661 BLAKE2B b2be54c03c12a2cdc641e329946bae37a7b8c1c4aee8ac686c6e3350f27cf7a0a2e64653afb8acac7e373f5cbbab05feba3c1c4d7e8856974621f0d1c96005df SHA512 3066f847c175ac26ab6918b71e84a8f87bc922f624011b707f8b0a6d872c123d7979a5ffec24a933b6f98a7f83bf530926ecccb5a1c6f24bd84b3fbda07fdf48
diff --git a/dev-python/nbclient/nbclient-0.5.11.ebuild b/dev-python/nbclient/nbclient-0.5.11.ebuild
new file mode 100644
index 000000000000..3c26e9ba6a0e
--- /dev/null
+++ b/dev-python/nbclient/nbclient-0.5.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client library for executing Jupyter notebooks"
+HOMEPAGE="
+ https://nbclient.readthedocs.io/en/latest/
+ https://github.com/jupyter/nbclient/
+ https://pypi.org/project/nbclient/"
+SRC_URI="
+ https://github.com/jupyter/nbclient/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter_client-6.1.5[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.0[${PYTHON_USEDEP}]
+ dev-python/nest_asyncio[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest