summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-04-19 08:29:21 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-04-19 08:34:08 -0400
commitd9d425553587706d37dc46a8fe4878a54b86040c (patch)
tree58aa9849dd9f033480e7ea9779789b19daf5d83a
parentnet-analyzer/nagios-check_multiple: stabilize 0.0.1-r2 for amd64 (diff)
downloadgentoo-d9d425553587706d37dc46a8fe4878a54b86040c.tar.gz
gentoo-d9d425553587706d37dc46a8fe4878a54b86040c.tar.bz2
gentoo-d9d425553587706d37dc46a8fe4878a54b86040c.zip
net-analyzer/nagios-check_multiple: drop 0.0.1-r1
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1-r1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1-r1.ebuild b/net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1-r1.ebuild
deleted file mode 100644
index 009545a959b7..000000000000
--- a/net-analyzer/nagios-check_multiple/nagios-check_multiple-0.0.1-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_9,3_10} )
-DISTUTILS_USE_SETUPTOOLS=no
-inherit distutils-r1
-
-MY_PN="check_multiple"
-DESCRIPTION="A Nagios plugin to execute multiple checks in parallel"
-HOMEPAGE="https://github.com/clarkbox/check_multiple"
-SRC_URI="https://github.com/clarkbox/check_multiple/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_install() {
- distutils-r1_src_install
-
- local nagiosplugindir="/usr/$(get_libdir)/nagios/plugins"
- dodir "${nagiosplugindir}"
-
- # Create a symlink from the nagios plugin directory to the /usr/bin
- # location. The "binary" in /usr/bin should also be a symlink, since
- # the python machinery allows the user to switch out the
- # interpreter. We don't want to mess with any of that, so we just
- # point to whatever the system would use if the user executed
- # ${MY_PN}.
- #
- # The relative symlink is preferred so that if the package is
- # installed e.g. while in a chroot, the symlink will never point
- # outside of that chroot.
- #
- dosym "../../../bin/${MY_PN}" "${nagiosplugindir}/${MY_PN}"
-}
-
-python_test() {
- "${EPYTHON}" -m unittest -v lib/check_multiple/check_multiple.py \
- || die "test suite failed"
-}