summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-09-07 00:05:13 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-09-07 00:29:33 -0700
commitdae57c0dc5d8170230823617874a4d75b8908db5 (patch)
treececfa9c5fc42b6444c031f1f57ca28857858b151
parentnet-dns/dnscrypt-proxy: add pie to live ebuild (diff)
downloadgentoo-dae57c0dc5d8170230823617874a4d75b8908db5.tar.gz
gentoo-dae57c0dc5d8170230823617874a4d75b8908db5.tar.bz2
gentoo-dae57c0dc5d8170230823617874a4d75b8908db5.zip
net-dns/dnscrypt-proxy: drop 2.0.15
Package-Manager: Portage-2.3.49, Repoman-2.3.10
-rw-r--r--net-dns/dnscrypt-proxy/Manifest1
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.15.ebuild98
2 files changed, 0 insertions, 99 deletions
diff --git a/net-dns/dnscrypt-proxy/Manifest b/net-dns/dnscrypt-proxy/Manifest
index 6fe73c2f3091..17454adf09dc 100644
--- a/net-dns/dnscrypt-proxy/Manifest
+++ b/net-dns/dnscrypt-proxy/Manifest
@@ -1,2 +1 @@
-DIST dnscrypt-proxy-2.0.15.tar.gz 2887764 BLAKE2B 7c4dd36f8305494566cb8548e478d9b89eed799dab124e574c0840c606f6c51cafb73818a07b18928a6457756a122d7bceabc108b1114b2b546d3db707d2ef3a SHA512 4517ab7b7eb1474f8c9e133a289caf6c02f472b51b910f1fbe1e5ffd6d389943626c8878e68f7f27a47b00301a427dfe9c563bc82b67cafab32f4ab3bc4c84b9
DIST dnscrypt-proxy-2.0.16.tar.gz 3770249 BLAKE2B e6dc40ec503cff11e4deec1a243875fff42ec7ecba8c7c3552b69322d405c762fa152e7e9417baf944e2a476715f00813a305c20db583970520d35acd378f1d4 SHA512 f138df20560dd440a2ed390c1468d630191ae7b0e50521b4dde3fa7ef4377c3ae6409e8c547858bace53216c84aeeea6794305546b9ff87832f704c160c6782f
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.15.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.15.ebuild
deleted file mode 100644
index 48aca6233183..000000000000
--- a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.15.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGO_PN="github.com/jedisct1/${PN}"
-
-inherit fcaps golang-build systemd user
-
-DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
-HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
-SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-
-FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
-PATCHES=( "${FILESDIR}"/config-full-paths-r10.patch )
-
-pkg_setup() {
- enewgroup dnscrypt-proxy
- enewuser dnscrypt-proxy -1 -1 /var/empty dnscrypt-proxy
-}
-
-src_prepare() {
- default
- # Create directory structure suitable for building
- mkdir -p "src/${EGO_PN%/*}" || die
- mv "${PN}" "src/${EGO_PN}" || die
- mv "vendor" "src/" || die
-}
-
-src_install() {
- dobin dnscrypt-proxy
-
- insinto /etc/dnscrypt-proxy
- newins "src/${EGO_PN}"/example-dnscrypt-proxy.toml dnscrypt-proxy.toml
- doins "src/${EGO_PN}"/example-{blacklist.txt,whitelist.txt}
- doins "src/${EGO_PN}"/example-{cloaking-rules.txt,forwarding-rules.txt}
-
- insinto "/usr/share/dnscrypt-proxy"
- doins -r "utils/generate-domains-blacklists/."
-
- newinitd "${FILESDIR}"/dnscrypt-proxy.initd dnscrypt-proxy
- newconfd "${FILESDIR}"/dnscrypt-proxy.confd dnscrypt-proxy
- systemd_newunit "${FILESDIR}"/dnscrypt-proxy.service dnscrypt-proxy.service
- systemd_newunit "${FILESDIR}"/dnscrypt-proxy.socket dnscrypt-proxy.socket
-
- einstalldocs
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- if ! use filecaps; then
- ewarn "'filecaps' USE flag is disabled"
- ewarn "${PN} will fail to listen on port 53"
- ewarn "please do one the following:"
- ewarn "1) re-enable 'filecaps'"
- ewarn "2) change port to > 1024"
- ewarn "3) configure to run ${PN} as root (not recommended)"
- ewarn
- fi
-
- local v
- for v in ${REPLACING_VERSIONS}; do
- if [[ ${v} == 1.* ]] ; then
- elog "Version 2 is a complete rewrite of ${PN}"
- elog "please clean up old config/log files"
- elog
- fi
- if [[ ${v} == 2.* ]] ; then
- elog "As of version 2.0.12 of ${PN} runs as an 'dnscrypt-proxy' user/group"
- elog "you can remove obsolete 'dnscrypt' accounts from the system"
- elog
- fi
- done
-
- if systemd_is_booted || has_version sys-apps/systemd; then
- elog "Using systemd socket activation may cause issues with speed"
- elog "latency and reliability of ${PN} and is discouraged by upstream"
- elog "Existing installations advised to disable 'dnscrypt-proxy.socket'"
- elog "It is disabled by default for new installations"
- elog "check "$(systemd_get_systemunitdir)/${PN}.service" for details"
- elog
-
- fi
-
- elog "After starting the service you will need to update your"
- elog "/etc/resolv.conf and replace your current set of resolvers"
- elog "with:"
- elog
- elog "nameserver 127.0.0.1"
- elog
- elog "Also see https://github.com/jedisct1/${PN}/wiki"
-}