summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-12-16 02:27:04 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-01-15 18:21:15 +0100
commitdb509b9eaf05b9871230afa9e1f5be61b60fb9e3 (patch)
tree28a19d2a5dd9b7cae3ba5ca1b1f14984b256498d
parentgames-board/gnuchess: Remove vulnerable (bug #599730) (diff)
downloadgentoo-db509b9eaf05b9871230afa9e1f5be61b60fb9e3.tar.gz
gentoo-db509b9eaf05b9871230afa9e1f5be61b60fb9e3.tar.bz2
gentoo-db509b9eaf05b9871230afa9e1f5be61b60fb9e3.zip
www-plugins/pdfjs: new ebuild.
A free browser plugin by Mozilla for PDF preview. Intended for use with qutebrowser. Closes: https://github.com/gentoo/gentoo/pull/3127
-rw-r--r--www-plugins/pdfjs/Manifest1
-rw-r--r--www-plugins/pdfjs/metadata.xml15
-rw-r--r--www-plugins/pdfjs/pdfjs-1.6.210.ebuild22
3 files changed, 38 insertions, 0 deletions
diff --git a/www-plugins/pdfjs/Manifest b/www-plugins/pdfjs/Manifest
new file mode 100644
index 000000000000..a65cc921fdae
--- /dev/null
+++ b/www-plugins/pdfjs/Manifest
@@ -0,0 +1 @@
+DIST pdfjs-1.6.210.zip 2682332 SHA256 53997edad2635983406a33d99c04db14b139aabbeddc63bc3b6cb60d830a4a90 SHA512 8b19aa6437448de93bb96408abe0db9168aec4452c61ff40329a4c796f0403153fa2e4845e526df3969eca49faebd6095280db03832f5e764077a15af605c35e WHIRLPOOL 5805690672fa5636c9f8a20ac93bb83ae096e22dccd9064ab177dde5df85d66adf775dfd61c562d95349983f7ef39099fb14fcb3aef14a909185baa98fef6510
diff --git a/www-plugins/pdfjs/metadata.xml b/www-plugins/pdfjs/metadata.xml
new file mode 100644
index 000000000000..1ce0d7605336
--- /dev/null
+++ b/www-plugins/pdfjs/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hilobakho@gmail.com</email>
+ <name>Mykyta Holubakha</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mozilla/pdf.js</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-plugins/pdfjs/pdfjs-1.6.210.ebuild b/www-plugins/pdfjs/pdfjs-1.6.210.ebuild
new file mode 100644
index 000000000000..c48277e4efde
--- /dev/null
+++ b/www-plugins/pdfjs/pdfjs-1.6.210.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A PDF reader in JavaScript"
+HOMEPAGE="http://mozilla.github.io/pdf.js/"
+SRC_URI="https://github.com/mozilla/pdf.js/releases/download/v${PV}/${P}-dist.zip -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/pdf.js/
+
+ doins -r build
+ doins -r web
+}