summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-04-01 18:17:53 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-04-01 18:18:06 +0200
commitdb91656281fd561a091f2659553026e7aa804455 (patch)
treed3103a6b5a99e5fb848acc27cc003162bd078228
parentdev-lua/luarocks: bump to version 3.6.0 (diff)
downloadgentoo-db91656281fd561a091f2659553026e7aa804455.tar.gz
gentoo-db91656281fd561a091f2659553026e7aa804455.tar.bz2
gentoo-db91656281fd561a091f2659553026e7aa804455.zip
sys-auth/AusweisApp2: bump to version 1.22.2
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.22.2.ebuild48
-rw-r--r--sys-auth/AusweisApp2/Manifest1
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.22.2.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.22.2.ebuild
new file mode 100644
index 000000000000..1a14a298ba88
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.22.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
index 71bc1f3358af..7df64f49a261 100644
--- a/sys-auth/AusweisApp2/Manifest
+++ b/sys-auth/AusweisApp2/Manifest
@@ -1,2 +1,3 @@
DIST AusweisApp2-1.22.0.tar.gz 10845370 BLAKE2B 2b35bece49c96f7aca391a918539115351737b9cc6bcb913121f7f44db7ff88fb615bd3a3822d7d5670e83c81ac7c409fffb1696d6dd9310fdbd595c3f7fa88f SHA512 c2340625f4792afccde2f09d54e050efed0e78a7d921f545ec73f4bf23746b7b0c422fffbc87822abe2dc8b69a8439615f3d43179a98a64fa4165503c2e74079
DIST AusweisApp2-1.22.1.tar.gz 10884409 BLAKE2B 3205bb4acd4145e20f336301c5a3dcb1da6d5fa1254169d0578d675dabb7b12fa84778b62a96ea4cae126800b4ef455b4e7a76154570090b8a74be41a1ba49b2 SHA512 3c66b401d370ae7f4ebb37a25c25d9eb044ec5706b85e656cb4a8ac0d3d6c922fe78f07a832635536f1e38896aad4aaf38ab4fd9bcdf00c9dac90e370b0f2232
+DIST AusweisApp2-1.22.2.tar.gz 10886670 BLAKE2B b3ab93549da146bb4108b4fa6981deb8e02c9f6143b8c5cf00f302999ded95e32db0a2180242b83558fbbe49101d385fc067b89554848de12872e6af3d82d4d2 SHA512 1ec777e2b4bef67fd7727ab21bfa2aeb5ad1e615b232fa8a3640fe3d6193a4f050f1824f421d9410d94c4e591fe46b48e1544701752724e4e300086f5cb9f27a