summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-31 20:05:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-31 20:07:11 +0100
commitdc2533225bfa9a9dbf27819b636100e6478554fb (patch)
tree8eb4147e79c9de7cd44f2c60a4c9b27338075c16
parentdev-php/PHP_CodeSniffer: Drop old (diff)
downloadgentoo-dc2533225bfa9a9dbf27819b636100e6478554fb.tar.gz
gentoo-dc2533225bfa9a9dbf27819b636100e6478554fb.tar.bz2
gentoo-dc2533225bfa9a9dbf27819b636100e6478554fb.zip
kde-plasma/plasma-integration: Ensure rebuild with Qt 5.14.1
Bug: https://bugs.gentoo.org/707658 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.17.5-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.17.5-r1.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.17.5-r1.ebuild
new file mode 100644
index 000000000000..315b84856988
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.17.5-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+KFMIN=5.64.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[dbus]
+ || (
+ >=dev-qt/qtgui-5.14.1:5[dbus]
+ <dev-qt/qtgui-5.14.0:5[dbus]
+ )
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"