summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-12-09 08:41:00 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-12-09 08:42:36 +0000
commitdc60ad82aff911e028aa5c9f63019b7f32135855 (patch)
treeda073d4a4cd501be7dd1fc8e36980ddf3874a1a5
parentapp-office/libreoffice-voikko: allow >=libreoffice-bin-6.4.7.2_p1 (diff)
downloadgentoo-dc60ad82aff911e028aa5c9f63019b7f32135855.tar.gz
gentoo-dc60ad82aff911e028aa5c9f63019b7f32135855.tar.bz2
gentoo-dc60ad82aff911e028aa5c9f63019b7f32135855.zip
dev-haskell/text-icu: tweak for icu-68.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-haskell/text-icu/files/text-icu-0.7.0.1-icu.patch12
-rw-r--r--dev-haskell/text-icu/text-icu-0.7.0.1.ebuild2
2 files changed, 14 insertions, 0 deletions
diff --git a/dev-haskell/text-icu/files/text-icu-0.7.0.1-icu.patch b/dev-haskell/text-icu/files/text-icu-0.7.0.1-icu.patch
new file mode 100644
index 000000000000..5a29309e7c45
--- /dev/null
+++ b/dev-haskell/text-icu/files/text-icu-0.7.0.1-icu.patch
@@ -0,0 +1,12 @@
+icu-68 disable TRUE/FALSE by default.
+--- a/cbits/text_icu.c
++++ b/cbits/text_icu.c
+@@ -305,7 +305,7 @@ int32_t __hs_u_strFoldCase(UChar *dest, int32_t destCapacity,
+
+ int32_t __hs_u_strCompareIter(UCharIterator *iter1, UCharIterator *iter2)
+ {
+- return u_strCompareIter(iter1, iter2, TRUE);
++ return u_strCompareIter(iter1, iter2, true);
+ }
+
+ UBlockCode __hs_ublock_getCode(UChar32 c)
diff --git a/dev-haskell/text-icu/text-icu-0.7.0.1.ebuild b/dev-haskell/text-icu/text-icu-0.7.0.1.ebuild
index 9a2bbca610d0..88b4ba6c94cb 100644
--- a/dev-haskell/text-icu/text-icu-0.7.0.1.ebuild
+++ b/dev-haskell/text-icu/text-icu-0.7.0.1.ebuild
@@ -20,6 +20,8 @@ IUSE=""
RESTRICT=test # QuickCheck occasionally finds counterexamples
# and fails to build: Duplicate instance declarations: instance NFData Ordering
+PATCHES=("${FILESDIR}"/${PN}-0.7.0.1-icu.patch)
+
RDEPEND=">=dev-haskell/text-0.9.1.0:=[profile?]
>=dev-lang/ghc-7.4.1:=
dev-libs/icu:=