summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-08 23:29:35 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-09 17:49:58 +0100
commitdc7bb4bbf7f8432432d6e330a92dd5ff38929718 (patch)
treee2fc29e1c6d7d09e41821506355ef6ba0dae06b4
parentsec-policy: Release of SELinux policies 2.20180701-r2 (diff)
downloadgentoo-dc7bb4bbf7f8432432d6e330a92dd5ff38929718.tar.gz
gentoo-dc7bb4bbf7f8432432d6e330a92dd5ff38929718.tar.bz2
gentoo-dc7bb4bbf7f8432432d6e330a92dd5ff38929718.zip
kde5-functions: Raise QT_MINIMAL to 5.11.1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--eclass/kde5-functions.eclass7
1 files changed, 5 insertions, 2 deletions
diff --git a/eclass/kde5-functions.eclass b/eclass/kde5-functions.eclass
index 319129dbbb7..2c3c7bdf5ee 100644
--- a/eclass/kde5-functions.eclass
+++ b/eclass/kde5-functions.eclass
@@ -35,19 +35,22 @@ export KDE_BUILD_TYPE
case ${CATEGORY} in
kde-frameworks)
[[ ${KDE_BUILD_TYPE} = live ]] && : ${FRAMEWORKS_MINIMAL:=9999}
+ [[ ${PV} = 5.52.0* ]] && : ${QT_MINIMAL:=5.9.4}
;;
kde-plasma)
if [[ ${KDE_BUILD_TYPE} = live && ${PV} != 5.??.49* ]]; then
: ${FRAMEWORKS_MINIMAL:=9999}
fi
- : ${QT_MINIMAL:=5.11.1}
+ ;;
+ kde-apps)
+ [[ ${PV} = 18.08.3* ]] && : ${QT_MINIMAL:=5.9.4}
;;
esac
# @ECLASS-VARIABLE: QT_MINIMAL
# @DESCRIPTION:
# Minimum version of Qt to require. This affects add_qt_dep.
-: ${QT_MINIMAL:=5.9.4}
+: ${QT_MINIMAL:=5.11.1}
# @ECLASS-VARIABLE: FRAMEWORKS_MINIMAL
# @DESCRIPTION: