summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2019-03-02 21:45:45 +0900
committerAkinori Hattori <hattya@gentoo.org>2019-03-02 21:45:45 +0900
commitdc8384f173ea1b1578cfd0fbc8c38879b248811c (patch)
tree605a388421a85e445cf3fa10b8be8928d2d7c7f1
parentdev-qt/qtspeech: Re-add ~arm to 5.12.1 (diff)
downloadgentoo-dc8384f173ea1b1578cfd0fbc8c38879b248811c.tar.gz
gentoo-dc8384f173ea1b1578cfd0fbc8c38879b248811c.tar.bz2
gentoo-dc8384f173ea1b1578cfd0fbc8c38879b248811c.zip
www-servers/h2o: fix build with >=dev-libs/libressl-2.7
Closes: https://bugs.gentoo.org/678430 Signed-off-by: Akinori Hattori <hattya@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--www-servers/h2o/files/h2o-2.2-libressl-2.7.patch23
-rw-r--r--www-servers/h2o/h2o-2.2.5.ebuild7
2 files changed, 28 insertions, 2 deletions
diff --git a/www-servers/h2o/files/h2o-2.2-libressl-2.7.patch b/www-servers/h2o/files/h2o-2.2-libressl-2.7.patch
new file mode 100644
index 000000000000..02942b49227f
--- /dev/null
+++ b/www-servers/h2o/files/h2o-2.2-libressl-2.7.patch
@@ -0,0 +1,23 @@
+From db50d885a87985310e65159a705b45de8646dc26 Mon Sep 17 00:00:00 2001
+From: AIZAWA Hina <hina@bouhime.com>
+Date: Fri, 23 Mar 2018 22:50:51 +0900
+Subject: [PATCH] Add supporting LibreSSL 2.7
+
+Signed-off-by: AIZAWA Hina <hina@bouhime.com>
+---
+ deps/neverbleed/neverbleed.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/deps/neverbleed/neverbleed.c b/deps/neverbleed/neverbleed.c
+index 29b35a9..42356a6 100644
+--- a/deps/neverbleed/neverbleed.c
++++ b/deps/neverbleed/neverbleed.c
+@@ -547,7 +547,7 @@ static int sign_stub(struct expbuf_t *buf)
+ return 0;
+ }
+
+-#if !OPENSSL_1_1_API
++#if !OPENSSL_1_1_API && (!defined(LIBRESSL_VERSION_NUMBER) || LIBRESSL_VERSION_NUMBER < 0x2070000fL)
+
+ static void RSA_get0_key(const RSA *rsa, const BIGNUM **n, const BIGNUM **e, const BIGNUM **d)
+ {
diff --git a/www-servers/h2o/h2o-2.2.5.ebuild b/www-servers/h2o/h2o-2.2.5.ebuild
index 3d4d736c3e88..de3a311b7555 100644
--- a/www-servers/h2o/h2o-2.2.5.ebuild
+++ b/www-servers/h2o/h2o-2.2.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -32,7 +32,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
)"
-PATCHES=( "${FILESDIR}"/${PN}-2.2-mruby.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2-libressl-2.7.patch
+ "${FILESDIR}"/${PN}-2.2-mruby.patch
+)
pkg_setup() {
enewgroup ${PN}